Can't compile LILO and Sysklogd

Bill's LFS Login lfsbill at wlmcs.com
Sat Jan 18 09:28:44 PST 2003


On Sat, 18 Jan 2003, [iso-8859-1] Manuel Vázquez Acosta wrote:

> Hi again:
>
> I’m not a member of the list, please reply directly to me.
>
> In my last post I said that I couldn't install LILO, the happened when
> trying to install sysklogd.
> It seems I miss a step installing other program
>
> Lilo says:
> /usr/include/linux/config.h:4:28: linux/autoconf.h: No such file or
> directory
> make: ***[lilo.o] Error 1
>
> And sysklogd says:
> /usr/include/linux/config.h:4:28: linux/autoconf.h: No such file or
> directory
> make: ***[ksym_mod.o] Error 1
>
> Both relying on linux/autoconf.h.
> Should I echo "" > linux/autoconf.h? Or I miss a step installing another
> program?

This seems to be a case of something before this did not install
correctly. If you have install logs, check them carefully and see if
you can locate the failure and fix it. If you have no logs, you may have
to compare the LFS book list of installed components for each package to
your /sbin, /usr/sbin, /lib and so on contents and identify which
package messed up.

More knowledgeable folks may be able to tell, based on the information
you gave what is wrong, but I can not.

Well, it would be good learning experience anyway.  :)

> Manu.

-- 
Bill Maltby
lfsbill at wlmcs.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list