Help with cfdisk

schof at coyotehighway.com schof at coyotehighway.com
Fri Jan 17 21:08:51 PST 2003


>> toggles bootable status on /dev/hda1, while down arrow gives an error.
>> I can't create or modify partitions 'cause I can't navigate to them.  I
>> don't get this...I'm running the RedHat GUI terminal on a local
>> computer, so there shouldn't be any WYSE/TTY/whatever configuration
>> problems, right?

>Yeah that's a pain sometimes. It depends on your $TERM setting.
>
>What is a "Redhat GUI terminal"? Is that xterm, eterm konsole, gterm or 
>something other?
>
>Either way, try this:
>
>Open your terminal, whatever it is.
>Run this: export TERM=xterm
>Then run cfdisk /dev/xxx


Thanks very much for your quick resonse, Gerard!  The "RedHat GUI Terminal" turns out to be gnome-terminal 2.0.1.  (The default terminal in my version of RedHat.)

I entered:

[root at SchofServer root]# export TERM=xterm
[root at SchofServer root]# cfdisk /dev/hda

(I probably shouldn't be doing this as root, but wanted to eliminate any permissions problems.)

Still get the same problem -- can't navigate with arrows; they don't translate right.  I did a search on the web -- tried a few other things:

[root at SchofServer root]# export TERM=gterm

[root at SchofServer root]# export TERM=gnome

[root at SchofServer root]# TERM=xterm-color
[root at SchofServer root]# export TERM


Nothing seems to make a difference. (Except the "gterm" line, which made cfdisk not work at all.)


Anywhere I should be looking for this info?


Schof


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list