cant get lilo to work

Bill's LFS Login lfsbill at wlmcs.com
Thu Jan 16 13:11:07 PST 2003


On Thu, 16 Jan 2003, dc_u wrote:

> Yes, i did run /sbin/lilo after making changes. The job of ez-bios is to
> enable windows to use my entire disk, so i think it may chache the disk
> geometry.

Aha! (I think). Especially with what you mention below.

> I did try making hda1 inactive and then making the extended partition active
> and hda5. I only got the message: 'no operating system' when i tried to
> boot.

That would be because the boot loader was not put in the first sectors
of the Mandrake partition. Something got missed in that setup. IIRC,
when the partition to boot is indicated in the MBR table (* = partition
to boot), the BIOS reads the first sector of the partition, expecting it
to be a boot loader (sometimes called stage 1?). Telling lilo (for
example) to install in the partition instead of the MBR would then
provide that boot loader.

Hey! Maybe that's what you want to try somewhere down the line? I don't
think it gets around the current issue - I still have a gut feeling that
it is geometry differences.

> Perhaps i should try grub, i guess i can find info on that in the lfs hints.
> I do have a backup of my MBR on a disk. It's the disk i installed ez/bios
> with. It's a utility called maxblast. It's for maxtor harddrives that is
> used with an old bios. the strange thing is that when i run the maxblast
> program it tells me that the harddrives actual heads are ony 16 while
> ez-bios says it 255 at boot time. the geom ez gives at boot time is:
> 255heads 63sectors and 4982cyllinders.

In all probability, *actual* heads is probably 1 or 2 or 3 unless the
drive is one of the *really* old ones that weight about a ton.

Bright idea! Usually there is a label on the drive that give the
recommended BIOS settings. Some give *both LBA* and CHS form. Can you
get a flashlight and mirror and read backwards and upside down while
scrunched into a doughnut shape? That would get us the "gospel" on the
drive params. Also, if you get the model number (avialable from Win and
/proc in linux) the mfg web site usually has those params. A lot are PDF
now, but Acrobat reader 5.0.x is a reasonably-sized download.

The maxblast is probably not truthful either? But seems that what we
have been suspecting is true. The ez-disk is jiggering the geometry.
*But*, maybe we have been coming from the wrong direction? Is possible
that when you try to boot LFS, ez-disk has not been invoked? Is it
started by the Win boot process? If so, the cure may be in finding what
the params are *in the BIOS*, figuring that at boot time, that is what
lilo sees? Maybe we have to lie for ourselves. I know how to do that! ;)

> The reason i'm using a floppy is because i've never succeeded in getting
> lilo to run. I had to use the distro cd and boot a rescue kernel and then
> make a bootdisk.
> Ill try to uninstall ez and see what happens.
> Thanks for your help so far!

Well, lots of theories - no answer yet.

> dc
><snip>

-- 
Bill Maltby
lfsbill at wlmcs.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list