strange problem(s) - hardware related?

Tim Binsted lfs at fambinsted.demon.nl
Sat Jan 11 03:30:09 PST 2003


I have had a similar problem (not just LFS related but also with SuSE and 
Linus kernels. What hardware are you using. I have a very old Athlon 650, one 
of the big ones  before the chips came out with two fans. Anyway there 
doesn't seem to be a problem there but there do seem to be problems with the 
chipset, the old ones. With me the problem will always occur if I use DMA to 
the discs. DMA off then the problem nearly never occurs under the heaviest 
load.

I have actually found the errors and posted the errors to the IDE teams. As 
you say when I run the system with Windows stuff (w98 etc.) then the problem 
doesn't occur. However I suspect (and hear) that Windows is somewhat less 
agressive in turns of how it uses the hardware. 

What is worth doing is running memtest86 for a night or two and play with the 
BIOS settings. Again this has made the system a bit more stable with the use 
of DMA. I have also tried all of the different kernels. What is true is that 
newer kernels are better, i.e. they go longer before the error occurs. 
However in my case I am convinved it is a real hardware error in the chipset. 
Apart from that I have no other suggestion.
On Saturday 11 January 2003 11:31, you wrote:
> Hello list,
> 
> 	I made my first LFS almost two years ago. Since then, I made many LFS
> builds on various hardware. I never had any unsolvable problem, at least
> not solvable by help of LFS-news archives :) But, my last build is
> choking, and I am out of luck, debugging it. I tried many "solutions"
> without success. Including but not limiting to kernel changes, gcc
> changes, new build, CFLAGS bashing, hardware changes ... you name it.
> The problem is as follows: box runs fine on itself, idles for days
> without any problems, but, when I do some IDE intensive job, *WITH*
> compiling (kernel-tree would do, mozilla, or anything big), it locks up
> solid, after 2-5 minutes. No SSH, no serial login, nothing. Logs are
> empty, also. Just plain lockup. I suspected hardware, as I earn my bread
> in software industry, and hardware is always firs suspect :) You guessed
> it, it didn't work. I changed MB (same model), CPU (same model), Video
> (Nvidia vs ATI vs Matrox), no luck. As I isolated all possible causes of
> malfunction down to CPU and MB, my strong guess here is that chipset is
> doing havoc. Easiest way to solve this one is to go for another
> chipset/MB. But I wont do it. What makes me angry here is that M$ new
> toy XP, works in this configuration for weeks without any glich. That is
> so frustrating. What I want to do is debug this thingie. Any insides or
> similiar problems would be appriciated. I paste my significant /proc
> entries along with this post.
> 
> 	Thank you for your time guys (and gals?) :)
> 
> BTW.	Last config (read -> this one) I ran, includes nmi_watchdog=2 and
> lockups are not often as before.
> 
> cat /proc/version
> Linux version 2.4.18-db (root at beast) (gcc version 3.2.1) #1 Sun Jan 5 
13:09:09 CET 2003
> 
> cat /proc/pci
> PCI devices found:
>   Bus  0, device   0, function  0:
>     Host bridge: VIA Technologies, Inc. VT8367 [KT266] (rev 0).
>       Master Capable.  Latency=8.  
>       Prefetchable 32 bit memory at 0xe8000000 [0xebffffff].
>   Bus  0, device   1, function  0:
>     PCI bridge: VIA Technologies, Inc. VT8367 [KT266 AGP] (rev 0).
>       Master Capable.  No bursts.  Min Gnt=12.
>   Bus  0, device   9, function  0:
>     Multimedia video controller: Brooktree Corporation Bt848 TV with DMA 
push (rev 18).
>       IRQ 5.
>       Master Capable.  Latency=32.  Min Gnt=16.Max Lat=40.
>       Prefetchable 32 bit memory at 0xef001000 [0xef001fff].
>   Bus  0, device  10, function  0:
>     Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 16).
>       IRQ 10.
>       Master Capable.  Latency=32.  Min Gnt=32.Max Lat=64.
>       I/O at 0xd000 [0xd0ff].
>       Non-prefetchable 32 bit memory at 0xef000000 [0xef0000ff].
>   Bus  0, device  11, function  0:
>     Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 8).
>       IRQ 11.
>       Master Capable.  Latency=32.  Min Gnt=2.Max Lat=20.
>       I/O at 0xd400 [0xd41f].
>   Bus  0, device  11, function  1:
>     Input device controller: Creative Labs SB Live! (rev 8).
>       Master Capable.  Latency=32.  
>       I/O at 0xd800 [0xd807].
>   Bus  0, device  17, function  0:
>     ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge (rev 0).
>   Bus  0, device  17, function  1:
>     IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 6).
>       Master Capable.  Latency=32.  
>       I/O at 0xdc00 [0xdc0f].
>   Bus  0, device  17, function  2:
>     USB Controller: VIA Technologies, Inc. UHCI USB (rev 27).
>       IRQ 11.
>       Master Capable.  Latency=32.  
>       I/O at 0xe000 [0xe01f].
>   Bus  1, device   0, function  0:
>     VGA compatible controller: ATI Technologies Inc Radeon VE QY (rev 0).
>       IRQ 11.
>       Master Capable.  Latency=32.  Min Gnt=8.
>       Prefetchable 32 bit memory at 0xe0000000 [0xe7ffffff].
>       I/O at 0xc000 [0xc0ff].
>       Non-prefetchable 32 bit memory at 0xed000000 [0xed00ffff].
> 
> cat /proc/interrupts
>            CPU0       
>   0:     418096          XT-PIC  timer
>   1:      11621          XT-PIC  keyboard
>   2:          0          XT-PIC  cascade
>   5:          2          XT-PIC  bttv
>   7:         76          XT-PIC  parport0
>   8:          0          XT-PIC  rtc
>   9:          0          XT-PIC  acpi
>  10:       3175          XT-PIC  eth0
>  11:       1185          XT-PIC  usb-uhci, EMU10K1
>  12:      55276          XT-PIC  PS/2 Mouse
>  14:      30615          XT-PIC  ide0
>  15:      23594          XT-PIC  ide1
> NMI:       2196 
> LOC:     418075 
> ERR:          0
> MIS:          0
> 
> cat /proc/cpuinfo
> processor	: 0
> vendor_id	: AuthenticAMD
> cpu family	: 6
> model		: 6
> model name	: AMD Athlon(tm) XP processor 2100+
> stepping	: 2
> cpu MHz		: 1733.446
> cache size	: 256 KB
> fdiv_bug	: no
> hlt_bug		: no
> f00f_bug	: no
> coma_bug	: no
> fpu		: yes
> fpu_exception	: yes
> cpuid level	: 1
> wp		: yes
> flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat 
pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
> bogomips	: 3460.30
> 
> cat /proc/mounts
> /dev/md/1 / ext3 rw 0 0
> none /dev devfs rw 0 0
> proc /proc proc rw 0 0
> /dev/md/0 /boot ext2 rw 0 0
> tmpfs /dev/shm tmpfs rw 0 0
> /dev/discs/disc0/part2 /mnt/windows ntfs ro 0 0
> /dev/discs/disc1/part2 /mnt/storage vfat rw 0 0
> gateway.hell.org:/ /mnt/gateway nfs 
rw,v3,rsize=8192,wsize=8192,hard,udp,lock,addr=gateway.hell.org 0 0
> 
> cat /proc/modules
> 8139too                13480   1 (autoclean)
> mii                     1024   0 (autoclean) [8139too]
> serial                 42692   0 (autoclean) (unused)
> radeon                 76824   1 (autoclean)
> agpgart                12008   3 (autoclean)
> nvram                   4052   0 (autoclean) (unused)
> rtc                     6552   0 (autoclean) (unused)
> tvmixer                 3472   0 (autoclean) (unused)
> tuner                   8192   1 (autoclean)
> tvaudio                 9692   0 (autoclean) (unused)
> bttv                   55872   0 (autoclean) (unused)
> i2c-algo-bit            6888   1 (autoclean) [bttv]
> emu10k1-gp              1256   0 (autoclean) (unused)
> gameport                1484   0 (autoclean) [emu10k1-gp]
> emu10k1                59336   0 (autoclean)
> ac97_codec              8968   0 (autoclean) [emu10k1]
> soundcore               3556   4 (autoclean) [tvmixer emu10k1]
> printer                 5664   0 (autoclean) (unused)
> ov511                  68824   0 (autoclean)
> videodev                4704   3 (autoclean) [bttv ov511]
> uhci                   23440   0 (autoclean) (unused)
> it87                    6404   0 (autoclean) (unused)
> i2c-isa                 1064   0 (autoclean) (unused)
> eeprom                  3316   0 (autoclean) (unused)
> i2c-proc                6608   0 (autoclean) [it87 eeprom]
> i2c-viapro              3632   0 (autoclean) (unused)
> i2c-core               13892   0 (autoclean) [tvmixer tuner tvaudio bttv 
i2c-algo-bit it87 i2c-isa eeprom i2c-proc i2c-viapro]
> nls_cp437               4284   1 (autoclean)
> vfat                    9244   1 (autoclean)
> fat                    29176   0 (autoclean) [vfat]
> ntfs                   46880   1 (autoclean)
> 
> cat /proc/iomem
> 00000000-0009fbff : System RAM
> 0009fc00-0009ffff : reserved
> 000a0000-000bffff : Video RAM area
> 000c0000-000c7fff : Video ROM
> 000f0000-000fffff : System ROM
> 00100000-0ffeffff : System RAM
>   00100000-00250331 : Kernel code
>   00250332-002aca1f : Kernel data
> 0fff0000-0fff2fff : ACPI Non-volatile Storage
> 0fff3000-0fffffff : ACPI Tables
> e0000000-e7ffffff : PCI Bus #01
>   e0000000-e7ffffff : ATI Technologies Inc Radeon VE QY
> e8000000-ebffffff : VIA Technologies, Inc. VT8367 [KT266]
> ec000000-edffffff : PCI Bus #01
>   ed000000-ed00ffff : ATI Technologies Inc Radeon VE QY
> ef000000-ef0000ff : Realtek Semiconductor Co., Ltd. RTL-8139
>   ef000000-ef0000ff : 8139too
> ef001000-ef001fff : Brooktree Corporation Bt848 TV with DMA push
>   ef001000-ef001fff : bttv
> ffff0000-ffffffff : reserved
> 
> cat /proc/ioports
> 0000-001f : dma1
> 0020-003f : pic1
> 0040-005f : timer
> 0060-006f : keyboard
> 0070-007f : rtc
> 0080-008f : dma page reg
> 00a0-00bf : pic2
> 00c0-00df : dma2
> 00f0-00ff : fpu
> 0170-0177 : ide1
> 01f0-01f7 : ide0
> 0290-0297 : it87
> 02f8-02ff : serial(auto)
> 0376-0376 : ide1
> 0378-037a : parport0
> 03c0-03df : vga+
> 03f6-03f6 : ide0
> 03f8-03ff : serial(auto)
> 0778-077a : parport0
> 0cf8-0cff : PCI conf1
> 5000-5007 : viapro-smbus
> c000-cfff : PCI Bus #01
>   c000-c0ff : ATI Technologies Inc Radeon VE QY
> d000-d0ff : Realtek Semiconductor Co., Ltd. RTL-8139
>   d000-d0ff : 8139too
> d400-d41f : Creative Labs SB Live! EMU10k1
>   d400-d41f : EMU10K1
> d800-d807 : Creative Labs SB Live!
>   d800-d807 : emu10k1-gp
> dc00-dc0f : VIA Technologies, Inc. Bus Master IDE
>   dc00-dc07 : ide0
>   dc08-dc0f : ide1
> e000-e01f : VIA Technologies, Inc. UHCI USB
>   e000-e01f : usb-uhci
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe lfs-support' in the subject header of the message
> 
> 
> 
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list