Problem with Xfree86 4.2.1, the friendly way

Tim Moore tim at moores.homeip.net
Fri Jan 10 07:20:52 PST 2003


** I am not a subscriber to the list

I am trying to install Xfree86 from the hints.linuxfromscratch.org.  I am
doing the install fromt he "Xfree86 4.2.1, the friendly way" link.  I have
a new install of LFS 4.0 on my box.  I ran everything as shown and I am
getting an error when I try to make install the Xfree86 files.  The make
World worked fine.  This error is from the make install:

make[3]: *** [xftfreetype.0] Error 1
make[2]: *** [install] Error 2
make[1]: *** [install] Error 2
make: *** [install] Error 2

I installed Freetype2 exactly as instructed.  I know there is a section in
there about creating some simlinks after installing the Xfree86 binaries. 
I tried to run those commands thinking maybe they were supposed to be run
prior to install as it shows up in the instructions before installing
Xfree86.  Basically, all of the simlinks and directories were already
there.  I then ran make install again and it got the same error.  However,
this time it added these lines and finished the make:

make[3]: *** [xftfreetype.0] Error 1
make[2]: *** [install] Error 2
make[1]: *** [install] Error 2
make: *** [install] Error 2
make[3]:  Leaving directory 'usr/src/xfree86-src/xc/lib/Xft'
make[2]:  Leaving directory 'usr/src/xfree86-src/xc/lib'
make[1]:  Leaving directory 'usr/src/xfree86-src/xc'

Any suggestions??

Thanks,
Tim


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list