Keyboard is dead, can't login

Alex delete.this.part.alex.news at attbi.com
Thu Jan 9 14:23:15 PST 2003


Mea Culpa.

I guess simply writing about a problem helps one think.

In /etc/fstab file I did not replace the *fs-type* for my lfs partition 
with the correct type (ext3 in my case).

I find the behavior that resulted from this mistake a bit strange, but 
thankfully it now works.

Once again, thank you to everybody who made lfs possible.  It is a great 
resource.  Onwards to blfs!

Alex



Alex wrote:
> Hello All,
> 
> I just ran through the entire lfs 4.0 book.  I give my thanks to all the 
> people who made it possible.  I have learned quite a bit. Unfortunately, 
> I'm a Linux newbie, and have hit a big problem that I cannot resolve.
> 
> When I boot my lfs system, everything seems to work and eventually I am 
> presented with a login prompt.  When I try to type a user name, nothing 
> happens.  The keyboard is completely dead!
> 
> I tried longing in anyway, thinking perhaps the characters were not 
> being echoed to the screen.  That didn't work.
> 
> I can ping the lfs machine from my laptop, so at least networking is up.
> 
> I have tried several different configurations from kernel menu 
> configuration program.
> 
> 1) Take the defaults - I get the behavior mentioned above
> 
> 2) Go into character devices and try lots of different combinations.  If 
> I do this, either the keyboard doesn't work, or the machine hangs during 
> the boot process after the line "freeing unused kernel memory"
> 
> 3) Use my host's .config file.  When I do this, the compile fails in 
> some SCSI code.
> 
> 3a) Same as above, but disable SCSI.  Now I can type and login, which is 
> good,  but my eth0 device does not go up! This despite the fact that the 
> correct Ethernet card is selected in the menu configuration program. 
> Ultimately I don't want to use my hosts .config as I intend to run a 
> minimal system as a web server on an old machine.
> 
> I have also tried kernel 2.4.20 with the same results.
> 
> My host is Red Hat 8.0 running kernel 2.4.18.  My machine is a Dell 8250 
> 2.4 GHz with 1GB of memory and a 120gb IDE hard drive.
> 
> I have searched through the archive to no avail.  I have also looked all 
> over the Internet.  I found several comments like this one:
> 
>     http://lists.insecure.org/lists/linux-kernel/2002/Oct/7302.html
> 
> but they all seem involve the 2.5 kernel.  I had no success adapting the 
> solution to my problem.
> 
> Please help!  I am stuck.  I have rebuilt the kernel 20 times now and 
> even re-built every package.  Needless to say, I am getting quite 
> frustrated.  Is there some configuration option to make your keyboard 
> work?  Any sugestion would be greatly appreciated.
> 
> Thanks,
> Alex
> 


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list