help compiling bash static

Martin Sand Roaster200 at netscape.net
Mon Jan 6 02:07:35 PST 2003


Hi Albert

Please type export into console and show us the output.
This could result from a wrong setting in the export parameters 
concerning the gcc settings.
In my case the pasting of commands from the lfs book replaces all - with 
a dot. That means
I had a "gcc .s" instead of a "gcc -s". Then the same error occured.

Best regards
Martin

Albert Wagner schrieb:

>Sorry, but I am having trouble getting started.
>I am running LFS 3.3 as host to build LFS 4.0 on another partition.
>I have:
>su-ed to user lfs
>run the setup script
>unpacked bash source
>changed dir to $LFS/usr/src/bash-2.05a
>tried to run the bash compile script and got:
>
>su-2.05a$ cd bash-2.05a
>su-2.05a$ ./configure --enable-static-link \
>
>>    --prefix=$LFS/static --with-curses &&
>>make &&
>>make install
>>
>checking build system type... configure: error: cannot guess build 
>type; you must specify one
>
>

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list