pb after compiling glibc

Tushar Teredesai tushar at linuxfromscratch.org
Sat Jan 4 08:57:11 PST 2003


Alex wrote:

>De : lfs-support-bounce at linuxfromscratch.org
>[mailto:lfs-support-bounce at linuxfromscratch.org]De la part de Tushar
>Teredesai
>
>Alex wrote:
>  
>
>>I did the following :
>>
>>../glibc-2.3.1/configure --prefix=/usr \
>>   --disable-profile --enable-add-ons \
>>   --libexecdir=/usr/bin
>>echo "cross-compiling = no" > configparms
>>make &&
>>make install
>>make localedata/install-locales
>>
>>Everything worked fine until the following :
>>I have no name!:/static/src/glibc-build# exec /static/bin/bash --login
>>Erreur de segmentation (core dumped)
>>[root at linux lfs]#
>>
>>As you can see it went out of the chroot environment...!!!
>>
>>Any clue?
>>    
>>
>Let me guess. You tried to install a glibc version that was different
>from the one mentioned in the book. Right?
>
>wrong...
>I installed a supported version, the 2.3.1 version as mentioned in the CVS
>version of LFS Book at
>http://linuxfromscratch.org/view/cvs/chapter06/glibc.html
>
>What I don't understand is that I am unable to chroot anymore to the lfs
>environment. It seems that something was corrupted by glibc compilation!!
>:-(
>  
>
<request>please bottom post your replies. Also, you mail client seems to 
be messing up the indentation of the replies. Please fix it.</request>

Did you apply the libnss patch to glibc when compiling?

-- 
Tushar Teredesai
   http://www.linuxfromscratch.org/~tushar/
   http://www.geocities.com/tushar/


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list