My patch won't work

wackman wackman2k1 at msn.com
Wed Jan 1 04:27:20 PST 2003


Chris Lingard <chris at stockwith.co.uk> wrote in
news:auul12$4v1$1 at quasar.highos.com: 

> wackman wrote:
> 
>> The first time I tried installing lfs, it was through VMWare on
>> Windows XP. I had a problem there when trying to chroot to my static
>> build. I could chroot there, but then I couldn't do much of anything
>> (env would work, but ls wouldn't). I was using the cvs doc dated
>> 12/21/2002. 
>> 
> 
> Every program in the chroot must work, probably the fileutils package
> is not static.
> 
> Return to chapter 5 and rebuild those packages that do not work.

ok, won't hurt to try again
> 
>> Starting tonight, I moved to a live linux system. I'm using Crux
>> (version 0.93, I believe) and LFS v 4.0 (dated October). Something I
>> did helped, The only thing that is worrying me is that it didn't
>> complain that it has no name yet - odd) At least I got quite a bit
>> farther than I had before. Now, I'm to the recompile of glibc and I
>> try to patch it, but it's telling me that it can't find patch, even
>> though patch is right there in /usr/bin. I even tried to do a
>> "./patch" directly from /usr/bin to see if it gave me an error about
>> no arguments specified. It just told me "/usr/bin/patch not found"
> 
> Within the chroot environment you will have no programs in /bin or
> /usr/bin -- this is what chapter 6 does.
> 

typo - I meant /static/bin

> patch should be in /static/bin/patch  --  does it work?  If not
> rebuild the patch package in chapter 5
> 
> You will not be able to build much in the chroot environment until
> glibc is built;  and to do this, the programs in static/bin must work
> 
>> 
>> I tried to recompile patch, but it first complained that it couldn't
>> tell what host type I was using, then it complained that my gcc
>> couldn't build executables. I would recompile gcc so that the system
>> could see that I can build executables, but I can't patch gcc so it
>> will compile. 
>> 
> 
> Sounds like your sh-utils is not working too.
> 
>> I tried to patch glibc by hand according to the LFS documentation (I
>> replaced $PERL with /usr/bin/perl and root with 0) as best I could,
>> but it didn't help. It wouldn't compile for me.
> 
> Check those programs in static/bin;  you can rebuild any package in
> chapter 5.
> 
> 
> 

no, it can find it, The actual response is:

:/#/static/bin/patch: File not found

that's including when I type patch by itself without specifying the path. 
It's almost like a permissions thing because it can find it, then it won't 
let me run it. But the message doesn't say anything about permission 
denied.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list