My patch won't work

wackman wackman2k1 at msn.com
Wed Jan 1 02:21:19 PST 2003


The first time I tried installing lfs, it was through VMWare on Windows XP. 
I had a problem there when trying to chroot to my static build. I could 
chroot there, but then I couldn't do much of anything (env would work, but 
ls wouldn't). I was using the cvs doc dated 12/21/2002.

Starting tonight, I moved to a live linux system. I'm using Crux (version 
0.93, I believe) and LFS v 4.0 (dated October). Something I did helped, The 
only thing that is worrying me is that it didn't complain that it has no 
name yet - odd) At least I got quite a bit farther than I had before. Now, 
I'm to the recompile of glibc and I try to patch it, but it's telling me 
that it can't find patch, even though patch is right there in /usr/bin. I 
even tried to do a "./patch" directly from /usr/bin to see if it gave me an 
error about no arguments specified. It just told me "/usr/bin/patch not 
found"

I tried to recompile patch, but it first complained that it couldn't tell 
what host type I was using, then it complained that my gcc couldn't build 
executables. I would recompile gcc so that the system could see that I can 
build executables, but I can't patch gcc so it will compile.

I tried to patch glibc by hand according to the LFS documentation (I 
replaced $PERL with /usr/bin/perl and root with 0) as best I could, but it 
didn't help. It wouldn't compile for me.

As a last resort, I copied over the patch from my host distro (I'm doing 
all this through 2 xterm sessions - one is the chroot environment, the 
other is without chroot, mainly so I can ls and see the stuff built as I go 
along). I used the non-chroot'ed xterm to copy patch from /usr/bin to 
/mnt/lfs/usr/bin. That didn't work, it kept saying that it doesn't exist.

Please help. Thank you.

Wackman
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list