unable to open an initial console

Lawrence O'Sullivan lawrence.osullivan at 141.com
Tue Oct 29 14:27:19 PST 2002

10/29/2002 4:12:35 PM, Greg Schafer <gschafer at zip.com.au> wrote:

>On Tue, Oct 29, 2002 at 03:51:07PM -0600, Lawrence O'Sullivan wrote:
>> Hi!
>> I could use some help with my LFS system. Everything was finished and seemed to compile 
corrctly, but the new LFS 
>> system doesn't run. Iget the following error:
>> 	Freeing unused kernel memory: 140k freed
>> 	Warning: unable to open an initial console
>> 	Kernel Panic: Attempted to kill init
>> I'm using LFS4.0. My original system is Mandrake 8.0. The system is on a QLITech Emperor 
laptop (same as Dell 
>> Inspiron 5000e), Pentium III 1GZh, 256mg RAM and 2gb for the LFS partition.
>> I've tried the suggestions from the archives. Didn't find anything useful on google, etc. I'm still 
pulling my hair out.  
>> Attached is a text file with a listing from mnt/lfs/dev, lilo.conf, fstab, and inittab. 
>Nice to see someone who actually researched the archives and went to a
>fair bit of effort to solve the problem themselves :) Now only if your
>Opera would word wrap the lines, this would have been the perfect post!
>> /mnt/lfs/dev# ls -l console tty tty0 tty1 tty2
>> crw--w--w-    1 root     root       5,   1 Oct 22 11:59 console
>> crw-rw-rw-    1 root     tty        5,   0 Oct 22 11:59 tty
>> crw--w--w-    1 root     tty        4,   0 Oct 22 11:59 tty0
>> crw-rw-rw-    1 root     tty        4,   1 Oct 22 11:59 tty1
>> crw-rw-rw-    1 root     root       4,   2 Oct 22 11:59 tty2
>Hmm, I just compared this against mine and the only difference is the
>console line which is owned by root:tty. Though I'd be surprised if that
>was the actual problem, but it might be worth trying.
>I couldn't spot any anomalies in your other config files. Another common
>cause of this problem is related to use of devfs, but you are not using
>devfs are you?
>Unsubscribe: send email to listar at linuxfromscratch.org
>and put 'unsubscribe lfs-support' in the subject header of the message

No, I'm not using devfs. The group was not the problem. I just tried, and also tried root and adm.

Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message

More information about the lfs-support mailing list