gcc 3.2 compile errors

kaiyi lin kaiyilin at compuserve.de
Wed Oct 23 08:50:19 PDT 2002


exactly, I tested yesterday like this. At firstly compiled gcc 3.2 fresh 
from Source and have one exit error. I then let my computer run for 5 
hours (let it do whatever it likes, mostly idle anyway). I compiled 
again after the first 5 hours and Got totally different error. I tried 
afterwards once again some time later and got another new error msg.
I assume that my CPU have overheat problem. I will check it with some
SW under windows and report them again.

Regards

Conrad Newton wrote:
> kaiyi lin on Tue, Oct 22, 2002 at 11:04:55AM +0200:
> 
>>I just built gcc 3.2 once again with fresh source code.
>>Interesting but also very frustrating that I got this time
>>totally different error msg. (I actually did it 2 times today and 2 
>>times this error msg)
>>
>>stage2/xgcc -Bstage2/ -B/static/i586-pc-linux-gnu/bin/ -c -DIN_GCC    -g 
>>-O2 -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes 
>>-Wtraditional -pedantic -Wno-long-long  -DHAVE_CONFIG_H    -I. -I. 
>>-I../../gcc-3.2/gcc -I../../gcc-3.2/gcc/. -I../../gcc-3.2/gcc/config 
>>-I../../gcc-3.2/gcc/../include \
>>        ../../gcc-3.2/gcc/config/i386/i386.c -o i386.o
>>../../gcc-3.2/gcc/config/i386/i386.c: In function 
>>`fcmov_comparison_operator':
>>../../gcc-3.2/gcc/config/i386/i386.c:3335: internal error: Segmentation 
>>fault
> 
> 
> See
> 
> http://www.bitwizard.nl/sig11/
> 
> I had problems of this kind last summer, with my AMD K6-2 300 MHz.
> There could be many reasons for your problem, including faulty
> memory, overheating, even a faulty CPU.  According to the writer
> of the above document,
> 
>  "I have the impression that most sig11 problems are caused by timing
>  errors on the CPU <-> cache <-> memory path."
> 
> The symptoms in my case were random compile failures in gcc and/or
> glibc.  Most other things would compile without problems.  But the
> failures in gcc and glibc would not go away, althougth they did
> not occur consistently in one place either.
>  
> I got hold of memtest86 from http://www.memtest86.com/
> and examined my two memory modules.  Both of them failed
> test 5, and only test 5 of memtest86, so if they were faulty, 
> both were faulty in the same way.  This seemed to suggest
> that my problems lay elsewhere.
> 
> To summarize, you probably have a hardware problem of some kind,
> although properly diagnosing it may be a frustrating experience.
> Hope for the simplest solution to your problems:  test for overheating,
> and for faulty RAM. before running out to buy a new motherboard
> and/or processor.  I finally capitulated, and bought a new computer. ;-)
> Although Chris Lingard suggested that my problems might be solved
> by underclocking.  Since hardware is mostly just a big mystery to me,
> I never looked into this possibility . . .
> 
> Conrad
> 
> error.message.gcc1:make[2]: *** [c-aux-info.o] Segmentation fault
> error.message.glibc1:make[1]: *** [localedata/subdir_install]Segmentation fault
> error.message.glibc2:make[2]: *** [/var/tmp/portage/glibc-2.2.5-r4/image//usr/share/i18n/locales/es_PR] Segmentation fault
> error.message.glibc3:make[1]: *** [termios/subdir_lib] Segmentation fault
> error.message.glibc4:make[1]: *** [stdio-common/subdir_lib] Segmentation fault
> error.message.glibc5:make[1]: *** [grp/subdir_lib] Segmentation fault
> 

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list