initrd, /dev/root, VFS, 2.4.19 hell :(

martial daumas martial at nasgaia.org
Wed Oct 23 01:41:00 PDT 2002


Hi all,

First of all, I9'd like to apologize if this post is a bit off-topic, 
i've really read tons of docs (google is my friend too ;-) and searched
trough archives, with for only result to get things even more confused
in my mind

Here's the fact: I need devfsd for our project (reiserfs, scsi etc..),
and When we used linux-2.4.18, I managed to create some initrd that *
worked, despite some ugly hacks (ie: initrd was not mount on /initrd but
/initrd/initrd ?? with some init scripts hack, it worked anyway). 
Problem came around when we upgraded to linux-2.4.19, nothing works
as before, i've tried tons (really) of variants, interactive linuxrc etc...
I always fall in something like:
VFS: unable to mount "<whatever>" or 03:03 
you should try to pass a correct root= option ....

In fact, this seems to be related to a problem with /dev/root (we're
using devfs, i forgot to mention that); but the more i read infos on
that topic, the more i get confused: it seems that kernel docs are
wrong on many points. I've tried things like passing /dev/ide/bla,
/dev/hd_bla, /dev/ram0, /dev/rd/0, /dev/root (i know it's stupid, but after 
50 tries....), mounting or not /dev , same thing in the /new-root, nothing
seems to work.

What i can't understand is that now, (i tested with running a /bin/bash
besfore the VFS crash) /initrd is used as described in kernel docs, 
everything in the linuxrc sequence works fine (module loading, etc..), but
it refuses to throw init, 'cause something goes wrong, and it can't find
the / part (but mount in linuxrc shows (depending of boot options) that
 /dev/root rootfs is there, and points the right place, that 
 /dev/ide/host0... is mounted on / (so, it _could_ find it, right?) ).
 
Here's where I'm stuck... If someone managed to run an initrd with
linux-2.4.18(or +, i tested 2.4.19-pre11 with same troubles), please
point me to the right solution. I'm almost sure i missed some _basic_
reading somewhere, so don't flame me please ;o)

ps: i can post my linuxrc if needed

thx in advance, any info would help

ciao 
-- 
Martial Daumas
Nasgaïa Gnu/linux http://www.nasgaia.org/
_-|| projet distro linux francophone alternative ||-_
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list