binutils-2.13 will not configure

drharlan at pacbell.net drharlan at pacbell.net
Mon Oct 21 11:36:06 PDT 2002


I'm in Chapter 6 of book 4 and ran into trouble compiling
binutils-2.13.  The consistent symptom is that, in the build directory,
it creates an empty directory 'i686-pc-linux-gnu', a file 'mtfrag'
containing the line 'CXXFLAGS_FOR_TARGET = $(CXXFLAGS) -D_GNU_SOURCE',
and a core dump. The output from the attempt is the following:

[root at home build-2.13]# ../binutils-2.13/configure --prefix=/usr --enable-shared
Configuring for a i686-pc-linux-gnu host.
Segmentation fault (core dumped)

Prior to this, I had installed bison-1.50 instead of 1.34 and this
required m4 so I did that ahead of the schedule in the chapter.  Then
after posting this "success" to lfs-dev, I was informed that 1.50 was
old and there was a 1.75.  So I did the usual 'make unintall' on 1.50
and did configure/make/make install on 1.75.  Same result (core dump) on
the binutils-2.13 attempt.  Then, I pretended to get smart and went
back to bison-1.34 per the book, again doing the make uninstall on the
old and configure/make/make install on 1.34. Same result on the
binutils attempt.

So, then I tried configuring binutils-2.12 and had no problems.  That's
where I am now and I plan to wait for a possible response before I go
ahead to install 2.12, in case there is a solution for 2.13.

So far, I have gone by the book except my statics are in /usr/local/...
I plan to avoid installing any new stuff in there until I can prune it
off.  Is this my problem ?

One other thing I did was to configure binutils-2.13 in my parent
system which did not fail.  In this parent system, gcc is 2.95.3, make
is 3.79.1 and binutils is 2.12.  Then returning to the chroot
environment, the make worked fine.  But I hesitated to install it until
I made this post.

Thanks for any help !


Wayne E. Harlan
drharlan at pacbell.net


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list