lfs init: Id "8" respawning too fast: disabled for 5 minutes

julius junghans juliusjunghans at gmx.de
Sat Oct 19 03:18:25 PDT 2002


On Fri, 18 Oct 2002 17:37:08 -0600
Gerard Beekmans <gerard at linuxfromscratch.org> wrote:

> On October 18, 2002 04:59 pm, julius junghans wrote:
> > hi
> > this message appears in my sys.log file for all consoles...i copied this
> > system from my workstation with cp -a, the dev dir was created with the lfs
> > 3.1 script (its an lfs system)
> > on my workstation this inittab works fine...but the copy bings up that
> > error whats wrong ?
> 
> You sure it says Id "8" respawning too fast and not Id "c8"?
> 
> If you meant c8 (and the same for the others like c1, c2, etc) then something 
> is wrong with your agetty lines. Like Billy said, try one from the LFS book 
> exactly as shown and see if it works then.
> 
> Something else you can try is this:
> 
> Boot the LFS system and pass the init=/bin/bash kernel parameter to your 
> bootloader (lilo or grub). Then when you get a shell, run those lines from 
> inittab and see if you get an error, so run:
> 
> /sbin/agetty 38400 tty2 linux
> 
> Switch to console 2 (alt+f2) and see if you can login. You probably can't 
> because you'll get an error when you run the above command since that's what 
> init tells you: the command exists immediately and therefore respawns too may 
> times.
> 
> -- 
> Gerard Beekmans
> www.linuxfromscratch.org
> 
> -*- If Linux doesn't have the solution, you have the wrong problem -*-
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe lfs-support' in the subject header of the message
> 

yes its not the original 3.1 inittab, but it works on my workstation...
i forgot to copy the first line, the missing default runlevel :

id:3:initdefault:

this inittab didnt worked too :
# Begin /etc/inittab

id:3:initdefault:

si::sysinit:/etc/rc.d/init.d/rc sysinit

l0:0:wait:/etc/rc.d/init.d/rc 0
l1:S1:wait:/etc/rc.d/init.d/rc 1
l2:2:wait:/etc/rc.d/init.d/rc 2
l3:3:wait:/etc/rc.d/init.d/rc 3
l4:4:wait:/etc/rc.d/init.d/rc 4
l5:5:wait:/etc/rc.d/init.d/rc 5
l6:6:wait:/etc/rc.d/init.d/rc 6

ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

su:S016:once:/sbin/sulogin

1:2345:respawn:/sbin/agetty tty1 9600
#2:2345:respawn:/sbin/agetty tty2 9600
#3:2345:respawn:/sbin/agetty tty3 9600
#4:2345:respawn:/sbin/agetty tty4 9600
#5:2345:respawn:/sbin/agetty tty5 9600
#6:2345:respawn:/sbin/agetty tty6 9600

# End /etc/inittab

i commented out 2 till 6 to test just if the sys works with 1...but i didn't
just gaves another error :
init: no more processes left in this runlevel

the cmd /sbin/agetty 38400 tty2 linux gives no error, after 5 mins the tty1 gives the respawning error again, but nothing about tty2...is that good ?



-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list