LFS 4, Lilo Version conflict solved

Hannes Birnbacher mail at hannes-birnbacher.de
Wed Oct 16 01:01:34 PDT 2002


Antwort auf die E-Mail vom Di 15 Okt 2002 11:08:36a :

>> Use the files from the new (LFS) /boot directory then. Make
>> a backup of the old /boot partition and copy the stuff over
>> from the LFS /boot directory.
> 
> Just for the record, booting stopped with "lilo: no
> signature" or so, so I could not access MS-Windows nor any
> of the Linux versions. 
> After applying the SuSE rescue systems I got a "message
> segment too big" error or similar, so I gave up for the time
> being. 

Of course I tried again an hour later;-). 
Just for the archive:

I have a separate, 16MB (not GB) partition as a boot partition. 
This makes sense: you can copy several kernels for multi-
boot there, there will be no trouble with the 1024-cylinder-limit 
etc.

I had mounted this partition via the LFS fstab as /boot like in 
the host distribution; in fact I copied /etc/fstab from my host 
distribution and later eliminated a few entries LFS did not yet 
know. This makes sense, too.

Furthermore, I used lilo.conf from the host distribution and 
added an entry for LFS, as described in the LFS Book (20021005). 

Using Lilo 21.7 from the host distribution made no problems. 
After Re-booting, however, Lilo 22.2 would not update the MBR 
which was written by Lilo 22.2, so I deleted the MBR with
lilo -U.
Lilo 22.2 still was unable to write a new MBR, complaining 
"message too big". Later I found out that my Host Distribution 
had a message (probably to make the Lilo boot screen nicer) 
mentioned in lilo.conf. I had to delete this line before I was 
able to have lilo write a new and working MBR.
There was an other error message (in fact, there were lots of 
other error messages ... there's a story of booting, re-booting, 
applying rescue-CD's several time etc. in between...;-) which I 
did not note down. It disappeared after I had backup'ed 
everything which had been in /boot from my host distribution and 
copied everything there which had been built in the local /boot 
files, when chrooted into LFS. In addition to that, I had to copy 
there the kernel and the system map, with their own file names  
from the host distribution so I am still able to boot that one.

Thanks to the LFS people and to everybody contributing to 
lfs.support, who all helped me to build my system and understand 
what I'm doing:-).
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list