Sh-utils-2.0: error from the configure script

Simon Comeau Martel martelsc at videotron.ca
Mon Oct 14 14:54:43 PDT 2002


On Mon, 14 Oct 2002 09:59:19 -0400
Simon Comeau Martel <martelsc at videotron.ca> wrote:

> LFS-CVS
> Chapter 6
> Installing Sh-utils-2.0
> 
> When I do ./configure --prefix=/usr  I get the following error:
> 
> patching file man/Makefile.in
> patching file src/Makefile.in
> creating cache ./config.cache
> checking host system type... i686-pc-linux-gnu
> checking for a BSD compatible install... /bin/install -c
> checking whether build environment is sane... configure: error: ls -t appears to fail.  Make sure there is not a broken
> alias in your environment
> configure: error: newly created file is older than distributed files!
> Check your system clock
> root:/usr/src/sh-utils-2.0# 
> 
> Does the problem come from /bin/ls ? I didn't got any previous error from it, and he seem to run well!  Anyway, just in case it can be usefull --> From my host distribution (LFS 3.3):
> 
> file $LFS/bin/ls
> 
> ls: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), stripped
> 
> Thx in advance
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe lfs-support' in the subject header of the message


I found that /bin/ls is broken, because when I try to run it, I get a Segmentation fault.  I didn't saw it, because when I run ls alone, I don't get any error (probably that /static/bin/ls is use).  I rebuild fileutils (with and without the patch) and always get the same error!  Maby the problem don't come from fileutils, because I can run $LFS/bin/ls without problem!!  How can I know what is wrong?  Can I still use the static version untill the end of my installation?
 
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list