Glib and glib-2.0

Tushar T tush at yahoo.com
Mon Oct 14 07:15:11 PDT 2002


Kai Wüstermann wrote:

>I tried to compile mc. This uses glib. So I downloaded glib-2.0 an 
>installed it. Run pkg-config but mc still didn't find glib.
>
>After one day I had the idea, to install glib-1.x an it works.
>
>So my question: I do not want to have a circus of different version of 
>lib and progs. So is there any way to link glib against glib-2.0.
>  
>
Check out http://www.linuxfromscratch.org/faq/ to determine which group 
is appropriate for your support request.

Also, check out BLFS book <http://beyond.linuxfromscratch.org> and the 
documentation (README, INSTALL, etc.) that comes with glib. One of the 
doc mentions that the glib-1.x and glib-2.x are not compatible and that 
they both can coexist.

Also, many packages have been updated to glib-2, so check out the 
documentation that comes with mc, there maybe a configure flag to link 
against later versions.

-- 
Tushar Teredesai
LFS ID: 1377
http://tushar.lfsforum.org/

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list