No SWAP and No Login Prompt

Aaron Lawrence Broad oube at myrealbox.com
Thu Oct 10 15:17:30 PDT 2002


Oh shoot.. maybe I am using devfs.. just copied my gentoo kernel
config.. gentoo uses devfs by default.  OK so I could disable devfs, and
it would work?

Should I keep devfs? Whats the benefit to it?  And if I do how do I help
my login prompt find the new devfs device names?

thanks,
Aaron

On Thu, 2002-10-10 at 19:20, Justin Hibbits wrote:
> On Thu, Oct 10, 2002 at 07:09:04PM -0300, Aaron Lawrence Broad wrote:
> > Hello,
> > 
> > I just installed LFS from the CVS dated Oct 6th, 2002.  Everything
> > compiled well.  And I added the new kernel to my GRUB boot manager in my
> > gentoo installation.  Rebooted. The kernel came up fine.. and the rest
> > of the boot script seemed to all work flawlessly except two problems:
> > 
> > The first one I think is minor in that the system should still work.
> > That is the swap device doesn't get "swapon"ed. Its says it can't stat
> > /dev/hda5 (which is my swap device).  It says so such file or device..
> > or something like that.I copied the line fromt he LFS manual with
> > /dev/hda5 set in my /etc/fstab.  That one didn't work.  SO I copied the
> > swap line from /etc/fstab on my gentoo partition and still the same
> > error.
> > 
> > I press enter to get throught th red text on that.  ANd everything else
> > comes up fine.  Lots of green OKs.. my networking, everything. Then it
> > gets to the point where I think it should display the login prompt but
> > it just stops.  Doesn't display a login prompt.  I waited from 20
> > mins..still nothing.  I though maybe it was /dev/pts.. so I tried
> > mounting and unmounting it in fstab.. still same error...   The system
> > isn't locked up though. because if I press ctrl-alt-delete it does a
> > nice orderly shutdown.
> > 
> > Anyways, if I get those two things working, its a great little book. 
> > Hope someone knows what my problem is.
> 
> Tell me this...are you using devfs? If not...are your devices created (maybe a
> stupid question, but you never know).
> 
> devfs changes the device names, so you would instead have
> /dev/discs/disc0/part5.  and your tty's become /dev/vc/*
> 
> Justin Hibbits
> 
> 
> -- 
> Registered Linux user 260206
> 
> "One World, One Web, One Program"
> 	- Microsoft Promo Ad
> "Ein Volk, Ein Reich, Ein Fuhrer"
> 	- Adolf Hitler
> 
> 
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe lfs-support' in the subject header of the message
> 
> 


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list