Textutils not statically linked (4.0)

Thomas Müller thmueller at myrealbox.com
Tue Oct 8 23:52:17 PDT 2002


Bob Kimmel schrieb:
>>Hi all
>>
>>Textutils do not work when in chroot mode. All other seems to
>>work so far. I
>>built textutils new several times, but no success. I checked cat with
>>"file" from the original distibution. The output from file says:  "ELF 32
>>bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.0,
>>dynamically linked (uses shared libs), not stripped.
>>
>>Because of this, Textutils can't work.
>>
>>Is it possible to link them statically "by hand" ? Or what lib I have to
>>inject ? Any othe idea's ?
>>
> 
> 
> First, what is the exact command you have used to build textutils?  Did
> you include the 'LDFLAGS=-static' in the make command?
> 
> Second, if you have done this, you say you have built the package
> several times.  Are you starting with a clean source tree each time?
> If the first time you ran make, you did so without 'LDFLAGS=-static',
> then running it again doesn't cause a recompilation, even if you
> include the static flag.  Running the configure script again
> doesn't help either.  Just a guess, but maybe this is what happened.
> 
> 
>>TIA and best regards
>>
> 
> 
> BK
> 
> Bob Kimmel
> 

Thanks for your input. Maybe I forgot the '-' in LDFLAGS=-static. No, I 
didn't start with a clean source tree with the new builds. I'll give it 
a try today evening.

Thomas Müller

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list