Compiling QT 3.x in LFS 3.3

Bob Kimmel rkimmel at princeton.edu
Tue Oct 8 12:31:33 PDT 2002


> I am attemting to compile QT 3.0.5 with the KDE
> configure options:
> 
> ./configure -system-zlib -qt-gif -system-libpng \
> -system-libjpeg -plugin-imgfmt-mng -thread -no-stl \
> -no-xinerama -no-g++-exceptions
> 
> When I run make, the build fails at random points due
> to "internal compiler errors". I've tried different
> configure options, and the only one that works is the
> one with no options at all (which won't work with KDE
> becuse it requires threading support). I was wondering
> if anyone else has had similar problems and what they
> did to solve them.
> 
> Vital system statistics:
> 
> AMD K6-2/450 128meg SD RAM
> LFS V3.3
> QT-x11-free-3.0.5
> XFree86 V4.2.0
> 

Hardware problem?

http://www.linuxfromscratch.org/faq/#AEN423

Is your system able to compile other large packages?  (glibc
is a good one to try)

BK

Bob Kimmel

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list