[fastdep] Error 135

John Moeller jmoeller at xmission.com
Sat Nov 30 12:59:03 PST 2002


Book ver: 4.0
Host ver: Red Hat 7.1
Section: 8.3. Installing Linux-2.4.19
Error: make[4]: *** [fastdep] Error 135  (more details below)
Deviation: None.  I have not deviated from the book at all, except to enter
the commands one-at-a-time.  I used 'make mrproper' again, and the problem
still occurred.

I completed 'make mrproper', 'make menuconfig' (fresh config), and received
the error in 'make dep'.  I received the error after another 'make
menuconfig && make dep', as well, and after another 'make mrproper'.

When I researched this error, I only found references to compiling an older
kernel (2.0.39, I think).  I don't know if I should trust this patch or not.
Has anyone else run into this problem?  If this has been brought up
recently, I'm sorry, but the archive search feature is not available, and I
really don't want to download the _whole_ archive just to find it (I did
look at the last two months, though, and there did not seem to be any
messages relating to this error).

Also, I would be willing to just excise the usb source if it would solve the
problem, but I don't know enough about compiling Linux kernels to feel
comfortable doing it.

Thanks,
John Moeller

Excerpt from 'make dep':

...
make[4]: Leaving directory `/usr/src/linux-2.4.19/drivers/telephony'
make -C usb fastdep
make[4]: Entering directory `/usr/src/linux-2.4.19/drivers/usb'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall -Wstrict-prototypes -
Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pip
e -mpreferred-stack-boundary=2 -march=i586  -nostdinc -I
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2/include -E -D__GENKSYMS__ hcd.c
| /sbin/genksyms  -k 2.4.19 >
/usr/src/linux-2.4.19/include/linux/modules/hcd.ver.tmp
mv /usr/src/linux-2.4.19/include/linux/modules/hcd.ver.tmp
/usr/src/linux-2.4.19/include/linux/modules/hcd.ver
gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall -Wstrict-prototypes -
Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pip
e -mpreferred-stack-boundary=2 -march=i586  -nostdinc -I
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2/include -E -D__GENKSYMS__ usb.c
| /sbin/genksyms  -k 2.4.19 >
/usr/src/linux-2.4.19/include/linux/modules/usb.ver.tmp
mv /usr/src/linux-2.4.19/include/linux/modules/usb.ver.tmp
/usr/src/linux-2.4.19/include/linux/modules/usb.ver
gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall -Wstrict-prototypes -
Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pip
e -mpreferred-stack-boundary=2 -march=i586  -nostdinc -I
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2/include -E -D__GENKSYMS__ ov511.c
| /sbin/genksyms  -k 2.4.19 >
/usr/src/linux-2.4.19/include/linux/modules/ov511.ver.tmp
mv /usr/src/linux-2.4.19/include/linux/modules/ov511.ver.tmp
/usr/src/linux-2.4.19/include/linux/modules/ov511.ver
gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall -Wstrict-prototypes -
Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pip
e -mpreferred-stack-boundary=2 -march=i586  -nostdinc -I
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2/include -E -D__GENKSYMS__
pwc-uncompress.c
| /sbin/genksyms  -k 2.4.19 >
/usr/src/linux-2.4.19/include/linux/modules/pwc-uncompress.ver.tmp
mv /usr/src/linux-2.4.19/include/linux/modules/pwc-uncompress.ver.tmp
/usr/src/linux-2.4.19/include/linux/modules/pwc-uncompress.ver
/usr/src/linux-2.4.19/scripts/mkdep -D__KERNEL__ -I/usr/src/linux-2.4.19/inc
lude -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-
common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i586  
-nostdinc -I /usr/lib/gcc-lib/i586-pc-linux-gnu/3.2/include -- CDCEther.c
CDCEther.h acm.c audio.c audio.h auerswald.c bluetooth.c brlvger.c catc.c
dabfirmware.h dabusb.c dabusb.h dc2xx.c devices.c devio.c drivers.c
dsbr100.c emi26.c emi26_fw.h hcd.c hcd.h hid-core.c hid-debug.h hid-input.c
hid.h hiddev.c hpusbscsi.c hpusbscsi.h hub.c hub.h ibmcam.c inode.c kaweth.c
kawethfw.h mdc800.c microtek.c microtek.h ov511.c ov511.h pegasus.c
pegasus.h printer.c pwc-ctrl.c pwc-if.c pwc-ioctl.h pwc-misc.c
pwc-uncompress.c pwc-uncompress.h pwc.h pwc_kiara.h pwc_nala.h pwc_timon.h
rio500.c rio500_usb.h rtl8150.c scanner.c scanner.h se401.c se401.h stv680.c
stv680.h uhci-debug.h uhci.c uhci.h ultracam.c usb-debug.c usb-ohci.c
usb-ohci.h usb-skeleton.c usb-uhci-debug.h usb-uhci.c usb-uhci.h usb.c
usbkbd.c usbmouse.c usbnet.c usbvideo.c usbvideo.h uss720.c vicam.c vicam.h
vicamurbs.h wacom.c > .depend
make[4]: *** [fastdep] Error 135
make[4]: Leaving directory `/usr/src/linux-2.4.19/drivers/usb'
make[3]: *** [_sfdep_usb] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.19/drivers'
make[2]: *** [fastdep] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.19/drivers'
make[1]: *** [_sfdep_drivers] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.19'
make: *** [dep-files] Error 2

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list