4.0 or cvs: Which one to use?

Jostein Christoffer Andersen jostein at josander.net
Sat Nov 23 14:12:54 PST 2002


Tushar Teredesai wrote:

>> It's still many programs that is troublesome when compiling with gcc-3.1,
>> (sometimes, I have to use 3.0.4 or 2.95.3).
> 
> Most of the programs compile without problems. There are patches
> available for programs that don't.

True, and I usally Googlelize and use Debian packages (or make them myself) 
whenever possible.
Sadly, it's many programs that don't have patches or are upgraded yet, and I 
hope that major Linux distros will come with the newest GCC's so some 
developers will be forced to do something about it.

This is some of the programs that don't compile on 3.1 and 3.0.4 but in 
2.95.3 (at least on my system):
wvstreams-3.70 (wvdial does on 3.1)
wvdial-1.53
yiff-2.12.4
mpgtx-1.3

Not in 3.1 but in 3.0.4:
gcc-2.95.3
neon-0.23.5

And as I understand, gcc 3.2.* are even more stricter (wich is a good 
thing), so I might have to compile and install 3.0.4 and 2.95.3 again.

Well, I think I will wait a little bit longer and see what the LFS-cvs or 
LFS-4.1 come up with.

Thanks for your comments.

Jostein

-- 


----------------------------------------------------------------------
Jostein Christoffer Andersen <jostein at josander.net>
http://www.josander.net/

Public PGP Key:
Key: http://www.josander.net/pub_keys/jostein_josander.net.asc
----------------------------------------------------------------------
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list