grub + reiserfs = kernel panic

rolf deenen rolf at deendyn.tmfweb.nl
Sun Nov 17 03:03:36 PST 2002


Hello,

I've just completed my installation of a LinuxFromScratch (LFS)
installation 4.0. I did not change a single thing with the
installation except for the fact that I installed LFS on a reiserfs
partition instead of a ext2 partition and because of this i installed
the reiserfs-tools instead of the ext2-tools.
When I tried to reboot the system (using lilo, as in the manual), it
gives me a screen filled with a scrolling 01 01 01 01 01 01 01 01 01
01 01 01 01 01 01 and on and on... . Because of this I installed grub
instead, hoping that this would go better. Well, it does in the
beginning since I get a nice grub-bootmenu. When I choose to boot LFS,
the kernel starts but ends in a kernel-panic (unable to mount root
partition at x:y). My question off course is why? This causes for me
several sub-questions (correct me if i missed something).

1. Does the fact that linux starts to boot, mean that my grub
installation is ok and that the problem is not grub?
2. Just before it creates the "kernel panic" it wants to do a
"modprobe". Does this mean that it's looking for a module to mount the
root-partition. This would be strange since i did include reiserfs
support in the kernel (no module).
3. In a suse mailing-list (a question about the same symptoms as I
have) I read something about disabeling "apic" support. Can this go
for me to, since I did include it too?

At the moment I don't have the installation-computer nearby, so it
could be I missed something.

Further:
-The installation was done from a debian host-system installed at
hdb1.
-This installation boots from floppy (because you can't boot from
hdb?)
-The LFS system is entirely installed at hda1 with swap on hda2
-When booting into grub i issue the following commands (although I'm
not completely certain and do not have the opportunity at the moment
to check):
     *root (hd0,0)
     *kernel (hd0,0)/boot/lfskernel root=/dev/hda1

I hope someone can help me out,

Rolf Deenen

PS: The complete error at boot is:
blahblahblah...
blahblahblah...
kmod: failed to exec /sbin/modprobe -s -k block-major-3, errno = 2
CFS: Cannot open root device "hda1" or 03:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 03:01



kmod: failed to exec /sbin/modprobe -s -k block-major-3, errno = 2
CFS: Cannot open root device "hda1" or 03:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 03:01
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list