Mounting Proc, permission denied error. (Chapter 6, LFS 4.0)

Chris Wesdorp chriswesdorp at planet.nl
Fri Nov 15 15:07:29 PST 2002


shane at dbtech.net wrote:
> NOTE: I am not subscribed to this list.  Be sure to CC me if replying.
> 
> I am working on a small project where I could possibly use LFS, so I recently 
> started installing LFS 4.0 following the book with no deviation.
> However, I soon ran into a problem in Chapter 6 after the initial chroot.  
> After chrooting and creating directories, I attempted to mount proc for the 
> first time.  I repeatedly recieved "permission denied".  Was I typing it right? 
> Yep.
> 
> I tried a few things such as mounting from outside chroot, but when I went to 
> the MAKEDEV step, I got errors w/ mknod creating the entries.  I was quite 
> miffed.  I hit the #lfs channel at irc.openprojects.net and a few folks were 
> quite helpful... We determined it might be the way /mnt/lfs was mounted... It 
> wasn't.
> 
> Well, after battling with this for a few hours, I finally found out what the 
> problem was... I am running Gentoo as the host with GrSecurity patches compiled 
> in the kernel.  If you have GrSecurity compiled in your kernel you will not be 
> able to mount proc, make devices, and/or other things from within your LFS 
> chroot.  :-)
> 
> Just lettin' ya'll know just in case somebody else has the same issue.  Oh, and 
> if anyone else has any information on this, like how to disable grsecurity 
> without recompile of kernel, let me (and the list) know.
> 
> -Shane
> 
> ----------------------------------------------
> This message sent compliments of db Technology
>            http://www.dbtech.net/
> 
> 
I'm planning to do a study on the RSBAC security system next few weeks. 
Maybe i'll encounter the same error, now i know where to find a possible 
solution. Thanks in advance...

Chris Wesdorp

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list