Book 3.3, Ch. 6, fileutils problem

Tomasz Korycki engine2 at flow.mine.nu
Wed Nov 6 08:01:13 PST 2002


At 19:36 2002-11-05, Tomasz Korycki wrote:
>At 18:44 2002-11-05, you wrote:
>
>>Tomasz Korycki wrote:
>> > /bin/sh: /missing: No such file or directory
>>
>>This looks to me like a problem with the autoconf or automake on your 
>>system..
>>Try rebuilding fileutils from a clean extract of the sources, and..
>
>I always use fresh extracts, as a matter of fact I have the whole 
>procedure scripted (including chroot'ing and then running chap6.sh from 
>the new / instead of shell), and the first few steps of the script pull 
>and uncompress fresh sources and a newly created slice, just so I don't 
>cut corners...
>
>>touch *
>>in the build dir first, to prevent autoconf automake from running.
>
>I like that idea... Will try it now and report
>
>>However, first check to see if there are any broken symlinks in the build dir
>>first.
>>If so, goto /usr and look for the automake dir, ie. something like
>>automake-1.5
>>I'm guessing there is no symlink named automake in /usr which points to
>>automake-1.5 ( or 1.7 etc... )
>>ln -s automake-1.5 automake
>>in /usr and try building again
>
>Everything is there as expected, I redirect stdout and stderr from the 
>chap6.sh to a file and browsing through it fileutils shows the first 
>problem. Didn't check further down, I know it will fail eventually. But 
>let me try the touch trick - and report back. It will be about an hour, 
>though...

Sorry this hour lasted so long... Other things. Anyway, when I touch'ed all 
in fileutils build directory before running ./configure, it worked. Thanks!


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list