fileutils segmentaion fault && gcc compilation error

Linux SEAQ - Andres Mauricio Mujica Zalamea linux at seaq.com.co
Sun Nov 3 04:18:52 PST 2002


Hi, i'm building my own lfs system (v 4.0) going on with chapter 5 and
need some help from you...

1. I using a Redhat 7.3 like host system, i compiled fileutils and get a
segmentation fault error when i try "ls" or any fileutils command...
i've use the patch and again the seg fault appear, removed evrything and
tried again with and without the patch and it gets the same error.. seg
fault.  What should i do??


2.  I don't know if i was wrong but, after that error, i just continued
compiling until i've reached gcc... i've applied patches as the book
said, start de compilation.. and it breaks with the next error
message... what should i do?? 



  prefix.o version.o    ../libiberty/libiberty.a
gcc -a -c -DIN_GCC    -g  -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -Wtraditional -pedantic -Wno-long-lo
ng  -DHAVE_CONFIG_H    -I. -I. -I../../gcc-3.2/gcc -I../../gcc-3.2/gcc/.
-I../../gcc-3.2/gcc/config -I../../gcc-3.2/gcc/../inclu
de ../../gcc-3.2/gcc/cppmain.c -o cppmain.o
gcc -a -DIN_GCC    -g  -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long 
 -DHAVE_CONFIG_H  -o cpp0 cppmain.o \
intl.o libcpp.a   ../libiberty/libiberty.a
./xgcc -B./ -B/static/i686-pc-linux-gnu/bin/ -isystem
/static/i686-pc-linux-gnu/include -isystem
/static/i686-pc-linux-gnu/sys-i
nclude -dumpspecs > tmp-specs
make[2]: *** [specs] Error 139
make[2]: Leaving directory `/misc/lfs/static/src/gcc-build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/misc/lfs/static/src/gcc-build/gcc'
make: *** [bootstrap] Error
-- 
Cordialmente,

Andrés Mauricio Mujica
linux at seaq.com.co
www.seaq.com.co

PS: Los documentos adjuntos se encuentran en formato PDF.
Para verlos descargue gratis www.acrobat.com


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list