patch-2.5.4 compiling problems (chapter 5)

Alexander Lesch alx1375 at compuserve.de
Sat Mar 30 10:45:08 PST 2002


I use mandrake 8.1! Kernel 2.4.8!
Maybe the gcc compiler makes the problem.
gcc -dumpversion says: 2.96
gcc -dumpmachine says: i586-mandrake-linux-gnu

man sigemptyset says:
#include <signal.h>

int sigemptyset(sigset_t *set);
int sigfillset(sigset_t *set);
int sigaddset(sigset_t *set, const int signum);
int sigdelset(sigset_t *set, const int signum);
int sigismember(const sigset_t *set, const int signum);

Do you see anything???

Thanks!


"Chris Lingard" <chris at stockwith.co.uk> schrieb im Newsbeitrag
news:a84r09$o3a$1 at shadowfax.linuxfromscratch.org...
> Alexander Lesch wrote:
>
> > Hello,
> >
> > I experienced following problem when compiling patch-2.5.4:
> >
> > LFS 3.2 page 48:
> >
> > after executing following command:
> > make LDFLAGS=-static
> >
> > following message appears:
> > gcc -c -D_GNU_SOURCES -DHAVE_CONFIG_H -Ded_PROGRAM\"/bin/ed\" -I.
> > -I. -g -02 util.c
> > util.c: In function 'set_signals':
> > util.c:730: incompatible types in assignment
> > make: *** [util.o] Fehler 1
> >
>
> This is a problem with the system that you are building from.
> What system are you using?
>
> Can you do     man sigemptyset
> If you have this man page then you may see:
> SYNOPSIS
>        #include <signal.h>
>
>        int sigemptyset(sigset_t *set);
>
> What does your system say?
>
> > What does this mean?
> > The patch-program is not installed.
> > I don´t have '/bin/ed' - is this the reason?
> >
>
> You will have /bin/ed in your future LFS system.
>
> > Please give me some hints!!
> >
> > Thanks!
> > Alexander
> >
> >
>




-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list