Can't compile fileutils in lfs book version 20020325

Gerard Beekmans gerard at linuxfromscratch.org
Thu Mar 28 20:23:20 PST 2002


On Wed, Mar 27, 2002 at 01:59:40PM -0700, Rob 'Feztaa' Park wrote:
> Alas! Rob 'Feztaa' Park spake thus:
> > Any thoughts? I've tried this with and without the patch for
> > amd/glibc-2.2.3, and I get the same error (which doesn't surprize me
> > because I'm using a pentium2 with glibc-2.2.4).
> 
> This is weird. I searched google and found a "fix", which worked for
> this error but just lead to other errors. Then I went and downloaded
> fileutils from the GNU site, and they compiled fine. Could the LFS
> CVS fileutils sources be corrupted in some way? Or perhaps they just
> corrupted in the download?

They are identical to the version on GNU. I just downloaded the version
from the GNU site and compared with what's on ftp.linuxfromscratch.org -
identical.

Perhaps you re-ran ./configure after the first time failed? I saw a line
saying "config.h unchanged" which means it already existed and wasn't
updated. This usually happens when ./configure was already ran. Now, when
you downloaded the GNU version you extracted a fresh copy. If you had
extracted the version from the LFS ftp site it would most likely have had
the same effect.
 

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list