Am I in the right place?

[f0r]hail frontierguard at mail.ru
Wed Mar 27 01:09:11 PST 2002


[f0r]hail -> Don Smith
#--------------------------------------------#

DS> some of the 3.0.x versions but they are being quickly eliminated. The
DS> latest, 3.0.4, seems to be pretty good. I'm trying it myself to see what
DS> fails.

I've tried to compile chapter6 using gcc-3.0.4, but i've got a weird
compile-time error trying to compile glibc... moving back to
gcc-2.95.3 solved the problem.

Seems to me there's no way to compile the whole LFS using 3.0.x
version... Anyways, if someone's done it, please tell me how ;))

#--------------------------------------------#
//Original message text//
DS> Only one stand out problem that is fading fast. Some applications will
DS> not compile with gcc-3.0.x and you need to use gcc-2.95.3 for them.
DS> These are mostly older code that used some constructs that are no longer
DS> allowed under the latest compilers. And there are still a few bugs in
DS> some of the 3.0.x versions but they are being quickly eliminated. The
DS> latest, 3.0.4, seems to be pretty good. I'm trying it myself to see what
DS> fails.

DS> You have a hard choice: use 2.95.3 and everything should compile and
DS> work just fine, but upgrading to gcc-3 will be a painful future project;
DS> or use 3.0.4 and realize some of you favorite apps might not work for a
DS> while.

DS> --
DS> Don
DS> LFS# 734


DS> "Mojo" <mojoman at flashmail.com> wrote in message
DS> news:3CA10226.3060806 at flashmail.com...
>> Awww... But thats my goal - to get EVERYTHING updated :( I want the
>> latest everything i think it just means i have to work harder :/
>>
>> cheers
>>
>> Anders Widman wrote:
>> >
>> >>Another mailing list - Oh no If its anything like this list - im
DS> gonan
>> >>get super-smaeed :P hehe oh well its worth it im sure!
>> >
>> >
>> >>another question - reading the book now do you *have* to use the
>> >>versions used on in the book? For isntance what if i used Xfree
DS> 4.2.0
>> >>instead of 4.1.0 it should be okay yes?
>> >
>> >
>> > Normally, this should't be a problem, however dependencies may be
>> > different for newer versions. You might want to look at that before
>> > going blindly after the latest and gratest =)
>> >
>> > //Anders
>> >
>>
>>
>>
>> --
>>
>> -( Mojo )
>> -( Switch7.NET )
>>
>>
>> --
>> Unsubscribe: send email to listar at linuxfromscratch.org
>> and put 'unsubscribe lfs-support' in the subject header of the message
>>

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list