autoloading modules at boot

Curtis Haas WonderBoy5150 at hotmail.com
Thu Mar 21 18:58:12 PST 2002


opps, just read that in the FAQ, my bad
sorry
  ----- Original Message ----- 
  From: Curtis Haas 
  To: lfs-support at linuxfromscratch.org 
  Sent: Thursday, March 21, 2002 9:55 PM
  Subject: autoloading modules at boot


  How can you get kernel modules to load automatically at boot.
  I was able to get my NIC to load when I first got LFS working a few weeks back by putting
  alias eth0 3c59x in the /etc/modules.conf, but now I want to get some of my other modules to load.
  Specifically:
  sb (soundblaster)
  awe_wave (soundblaster awe wave effects)

  I looked in my host distro's /etc/modules.conf and see:
  alias sound-slot-0 sb
  alias synth0 awe_wave

  But when I add these to the LFS system's /etc/modules.conf, they don't load after I reboot.
  I know the modules work when I 'modprobe' them, just can't get them to load at boot time.
  Are the sound-slot-0 and synth0 devices (/dev/xxx) or variables?
  I am thinking the system just doesn't know what sound-slot-0 and synth0 are...

  And why is it that when I save the modules.conf file, during boot up I get a message saying something like:
  insmod: something something /etc/modules.conf is newer than /lib/modules/2.4.17/modules.dep

  appreciate the help
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20020321/9f6d65f6/attachment.html>


More information about the lfs-support mailing list