Diffutils installation...

Mikael Johansson mikael at uppdragshuset.lidkoping.se
Tue Mar 19 06:36:26 PST 2002


Howdy,

I kinda got stuck here in chapter 5 while trying to install diffutils...

I've tried both approaches from the lsf-command/chapter5/diffutils scripts
and they both render the same error messages....

lfs at host:/mnt/lfs/tmp/src/d/diffutils-2.7$ ./configure --prefix=$LFS/usr &&
make LDFLAGS=-static PR_PROGRAM=/usr/bin/pr
&& make install

loading cache ./config.cache
checking for gcc... (cached) gcc
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for a BSD compatible install... (cached) /usr/bin/ginstall -c
checking for POSIXized ISC... no
checking for minix/config.h... (cached) no
checking for working const... (cached) yes
checking whether cross-compiling... (cached) no
checking for ANSI C header files... (cached) yes
checking for unistd.h... (cached) yes
checking for fcntl.h... (cached) yes
checking for limits.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for sys/file.h... (cached) yes
checking for time.h... (cached) yes
checking for dirent.h that defines DIR... (cached) yes
checking for -ldir... (cached) no
checking for -lx... (cached) no
checking whether stat file-mode macros are broken... (cached) no
checking for sys/wait.h that is compatible with Posix.1... (cached) yes
checking for pid_t... (cached) yes
checking return type of signal handlers... (cached) void
checking for dup2... (cached) yes
checking for memchr... (cached) yes
checking for sigaction... (cached) yes
checking for strchr... (cached) yes
checking for strerror... (cached) yes
checking for tmpnam... (cached) yes
checking for memchr... (cached) yes
checking for waitpid... (cached) yes
checking for working alloca.h... (cached) yes
checking for alloca... (cached) yes
checking whether closedir returns void... (cached) no
checking for vfork.h... (cached) no
checking for working vfork... (cached) yes
checking for vprintf... (cached) yes
checking for st_blksize in struct stat... (cached) yes
updating cache ./config.cache
creating ./config.status
creating Makefile
creating config.h
config.h is unchanged
gcc -o diff -g -O -static diff.o analyze.o cmpbuf.o dir.o io.o util.o
context.o ed.o ifdef.o normal.o side.o fnmatch.o getopt.o getopt1.o regex.o
version.o
/usr/lib/libc.a(regex.o): In function `init_syntax_once':
/tmp/glibc-2.1.3/posix/regex.c:257: multiple definition of `re_max_failures'
regex.o:/mnt/lfs/tmp/src/d/diffutils-2.7/regex.c:112: first defined here
collect2: ld returned 1 exit status
make: *** [diff] Error 1

as i stated it makes no difference if i use the
export CPPFLAGS=-Dre_max_failures=re_max_failures2 &&
./configure --prefix=$LFS/usr &&
unset CPPFLAGS &&
make LDFLAGS=-static PR_PROGRAM=/usr/bin/pr &&
make install
approach....

oh and i'm using lfs v 3.2
the host system is a slackware 7.1 installation used for nothing else than
as a host for lfs installation =)

thx in advance for any replies

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list