CH.6 compil.Glibc-prob

L.B. JLB at gmx.de
Sun Mar 17 12:39:37 PST 2002


Hello,

I did everything like in the 3.1 book until Ch.6. Up to now it seems to 
work. But now after running Glibc install by the recommended commands (page 
53) I got his message:

running configure fragment for ... 
../glibc-2.2.4/linuxthreads/sysdeps/unix/sysv/linux
running configure fragment for ...
../glibc-2.2.4/sysdeps/unix/sysv/linux
checking installed linux kernel header files ...too old!
configure: error: gnu libc requires kernel header files from
Linux 2.0.10 or later to be installed before configuring.
The kernel header files are found usually in /usr/include/asm or 
/usr/include/linux; make sure these directories use files from Linux 2.0.20 
or later. This check uses <linux/version.h>, so make sure that file was 
build correctly when installing the kernel header files.To use kernel 
headers not from /usr/include/linux , use the configure options 
--with-headers.

Only i did two things different from the book.

1. I used linux-2.4.17 instead of 2.4.16
2. I copied the dir linuxthreads (package) into glibc-2.2.4 directory, 
because I didn't find glibc-linuxthreads

I'm an Newbie, so please answer most correctly ;-)

THX to all - JLB
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list