stuck on chroot

Lewi ichtus at mbone.petra.ac.id
Fri Mar 15 19:25:22 PST 2002


On Thu, Mar 14, 2002 at 12:36:50PM -0500, Gerard Beekmans wrote:
> On Fri, Mar 15, 2002 at 12:16:01AM -0500, Lewi wrote:
> > [root at me /root]# cd $LFS &&
> > > chroot $LFS /usr/bin/env -i HOME=/root TERM=$TERM /bin/bash --login
> > [root at me /lfs]#
> > 
> > and nothing happen like maybe on the book wrote that the bash prompt will changed
> 
> Did you read this part on the chroot page:
> 
> Note that the bash prompt will contain "I have no name!" This is normal
> because Glibc hasn't been installed yet.
> 
> 
> You should see a prompt like:
> I have no name!:~/root# 
> 
> If you don't see this, perhaps you didn't create the
> $LFS/root/.bash_profile properly as the book suggests (which sets the PS1
> variable to make you prompt look like the one shown above).

yes I read that, I try to run .bash_profile manually (sh $LFS/root/.bash_profile) and the prompt change
but from chroot can't run that, what's wrong? I check that env in my $LFS dir is already installed, so why after I ran chroot bla bla didn't make the result.

or what I must check to make sure this work?
I look at -i as parameter on chroot, to clear any environment before, but it seem useless
I look at my env, didn't look changed.
what I must do to look why chroot didn't work?

thank you

> 
> 
> 
> -- 
> Gerard Beekmans
> www.linuxfromscratch.org
> 
> -*- If Linux doesn't have the solution, you have the wrong problem -*-
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe lfs-support' in the subject header of the message

-- 
ichtus
------
Lewi Supranata .K
ICQ: 50643061
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20020315/8e956a69/attachment.sig>


More information about the lfs-support mailing list