glibc-2.2.5 install problems (lfs-3.2)

Ken Moffat ken at kenmoffat.uklinux.net
Sat Mar 9 14:21:41 PST 2002


Hi,

 I've been trying to install 3.2 since shortly after RC1 came out (on and
off, interrupted by a series of hardware problems on my other box which
has the connectivity). I was in the middle of writing a script to install
chapter 5+ (based on the keep_chapters_5_and_6_separate hint), when RC1 
came out, and my first assumption was that I'd screwed up in that, 
because I couldn't see any similar *recent* postings. First time round I
hacked `manual/Makefile' until I could get the rest of glibc installed.
After that there were errors in `gettext', and then more errors in, I
think, texinfo, at which point I called an end to that attempt. Shortly
afterwards, I accidentally wiped most of /home while clearing out the
target partition, so I no longer have my logs of where the errors were.
[ a word to the wise - mounting other partitions from chroot is very
convenient, but remember to umount them first if you need to
`rm -r $LFS/*' ;) ] Anyway, I've gone for a straight follow-the-book
install this time, and I'm seeing the same error in glibc during `make
install' (copied by hand)

make -C manual subdir_install
make[2]: Entering directory `/usr/src/glibc-2.2.5/manual'
LANGUAGE=C LC_ALL=C makeinfo libc.texinfo
./libc.texinfo:106 Next reference to nonexistent node `Introduction'.
./libc.texinfo:116 Prev reference to nonexistent node `Contributors'.
makeinfo: Removing output file `/usr/src/glibc-2.2.5/manual/libc.info' due
to errors: use --force to preserve.
make[2]: *** [libc.info] Error 2
make[2]: Leaving directory `/usr/src/glibc-2.2.5/manual'
make[1]: *** [manual/subdir_install] Error 2
make[1]: Leaving directory `/usr/src/glibc-2.2.5'
make *** [install] Error 2

I had a bit of trouble with the search engine on LFS (sometimes I got
empty pages after the first page of results, and it looked as if it was
searching the whole of the site each time, instead of just this list), but
the results I found were for a similar problem in past times requiring
people to use texinfo-4.0. Just in case, I tried installing texinfo-4.1
statically, but it didn't make any difference. Apologies if this _has_
come up recently (I've only just subscribed to this list), if not can
anybody suggest where I should be looking to understand what I'm doing
wrong, please ?

FWIW, the host system is LFS-3.0-rc1.

Ken
-- 
pppg_penguin.linux.bogus 2.4.17-jl15-ll 2011.95 BogoMIPS

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list