installing fileutils, distro using glibc 2.2.4

Gerard Beekmans gerard at linuxfromscratch.org
Fri Mar 1 15:08:46 PST 2002


On Fri, Mar 01, 2002 at 01:15:25PM -0800, Keith Godin wrote:
> I swear, i've tried to find the answer to this question in the
> mailing
> list archives, on the lfs website, etc., but please forgive me
> if it has
> already been asked:
> My distro(suse 7.3) uses glibc 2.2.4, and i'm attempting to
> install
> fileutils 4.1 using Linux From Scratch: Version 3.2-rc2(chapter
> 5).
> I can't exactly tell what i should do, maybe its just me but the
> instructions seem rather ambiguous. I'm referring to the glibc
> sed
> patching when having an AMD processor. Now, what i'm wondering
> is whether I need to run the sed command. Sometimes the book
> seems to be saying 2.2.3 or higher need the patching, other
> times it
> says you only need to run it if you have 2.2.3. Any hints?

Yes, sometimes the book says glibc-2.2.3 or higher, sometimes only when
it's exactly glibc-2.2.3. Those aren't faulty instructions, they are
correct. As far as the fileutils installation goes. Only run that sed
command if the following two conditions apply:

	1) Your host distro uses glibc-2.2.3 or higher (*)
	2) You have an AMD CPU

(*) I haven't heard reports of glibc-2.2.4 and glibc-2.2.5 in regards to
this problem. Right now we're assuming you need to run the sed, but if
somebody can prove that not to be true, do let us know so we can adjust
this. I don't have an AMD powered machine myself so I can't test it.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list