Help! file-3.36

Jim Brewster bardobro at toad.net
Fri Sep 28 23:53:05 PDT 2001


I'm install LFS 3.0 on a Pentium 75 box. My base system is Slackware
7.0, kernel 2.2.19.

My problem started (I think) installing gcc in Chapter 6. It gave the
error 'bash: autoconf: command not found' or something like that, even
though autoconf is not listed as a requirement for installing gcc. So
I exited of my chroot and tried compiling autoconf statically. I don't
even remember the commands and flags I used, something like:
'./configure --disable-nls --prefix=$LFS/usr && make LDFLAGS=-static
&& make install'

So far so good. Gcc installed apparently without a hitch, and
subsequent packages as well up through flex.

Now in file-3.36, I get the following exit error from configure:
'NONE:0: /usr/bin/m4: Cannot open
/mnt2/lfs/usr/share/autoconf/autoconf.m4f: No such file or directory'

Of course it won't find that path: I'm chroot'd to /mnt2/lfs. But why
is it looking in that path? I'm guessing it has something to do with
statically installing autoconf, but I had already recompiled it in the
chroot environment. I tried reinstalling autoconf, mawk (the first
error said gawk was broken), and m4, all to no avail.

How can I get this fixed? I'm not real experienced with manually
editing Makefiles or configs but am willing to learn.

TIA,
Jim

-- 
Jim Brewster
bardobro at toad.net
http://www.toad.net/~bardobro/
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list