Unable to build glibc2.2.4 wit Mandrake8.0

Gerard Beekmans gerard at linuxfromscratch.org
Thu Sep 27 07:23:53 PDT 2001


On Thu, Sep 27, 2001 at 04:02:46PM +0200, Romeo Kienzler wrote:
> hi folks,
> 
> my "mother-linux" for lfs ist mandrake 8 with kernel 2.4.3 and glibc2.2.2.
> The first error ist that he wants to addon linuxrthreads. So I copied the
> directory "linuxthreads" to /usr/src/glibc2.2.4/linuxthreads and tried it
> with the option --enable-addons=linuxthreads from the ./configure-script.
> Still the same problem.

did you copy the linuxthreads_db directory too? You shouldn't just copy
directories, but actually unpack the tarball inside the glibc-2.2.4
directory like the instructions tell.

> Now I tried it with the
> option --enable-kernel=2.4.3 --with-headers=/usr/src/linux
> The errormessage was:
> checking for kernel header at least 2.4.3... too old !
> The aviable kernel heaaders are older than the requested compatible kernel
> version, but all is 2.4.3 ! the headers and the running kernel !

Enter chroot like you did in the beginning of chapter 6. Then run:
	cat /usr/include/linux/version.h

if the file doens't exist, or doens't contain something like this:
#define UTS_RELEASE "2.4.10"
#define LINUX_VERSION_CODE 132103
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))

then exit chroot, go back to chapter 5 and redo the part where you setup
the kernel.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list