Unresolved Symbols

XiPHiaS at gmx.net XiPHiaS at gmx.net
Mon Sep 24 03:00:02 PDT 2001


A few weeks ago i started installing a lfs system on a LVM logical volume. I
am running SuSE linux 7.1 on this system. Everything went fine, even with
the optimalization flags I used (I know this might be the cause of the problem,
but seems unlikely to me).

Anyway, when I tried to boot the LFS system the kernel told me that it
couldn't find the root on "a1:01" or something like that. I checked if LVM was
compiled in the kernel, and it was. But you have to run a vgscan before you're
able to access any LVM volumes. LVM has a utility called lvmcreate_initrd
which creates a initrd with vgscan on it image for your kernel. The strange thing
was that it seemed to work if I made one for my running 2.4.0 SuSE kernel,
but didn't work when I made one for the new 2.4.8 lfs kernel. I also compiled
devfs support in the kernel and found out that I should start devfsd to make
it work (this creates compatibility links to the new devices in the /dev
filesystem), but this didn't fix my problem with the 2.4.8 initrd image, because
it starts working after the root filesystem is mounted (but even when I put
the devfsd in the initrd image it won't work).
Then I found out that the 2.4.0 image loaded the lvm-mod module. I think
this makes devfs realize it should create LVM devices (I'm not completely sure
about his). So I decided to build the LVM support as a module in my 2.4.8
kernel. Then I made a new initrd image. But when I did this depmod started
complaining about unresolved symbols in about every module (When I booted lfs
system with the 2.4.0 initrd image  as well as when I chroot to the lfs volume and
do a "depmod 2.4.8 -a"). lvmcreate_initrd uses depmod to put the right
modules on the initrd image. I made a initrd image of my own and put the 2.4.8
lvm-mod module in it. But when I tried it the module complained about a lot of
unresolved symbols and didn't load. 
There are some other strange things: I tried to compile my 2.4.0 SuSE kernel
on my lfs system to test if this would also produce a lot of unresolved
symbols. But I didn't even compile (and it does on the SuSE system)! This is what
"make bzImage" said:

bbootsect.s: Assembler messages:
bbootsect.s:836: Warning: indirect lcall without `*'
ld -m elf_i386 -Ttext 0x0 -s -oformat binary bbootsect.o -o bbootsect
ld: cannot open binary: No such file or directory
make[1]: *** [bbootsect] Error 1

Another strange thing is that lilo doesn't work when i booted the lfs system
(with the 2.4.0 initrd). It says that it doesn't know what to do with the
device at "a1:01" (or something like that). I thought it should be a devfs
problem and changed lilo.conf to use devfs devicenames, but stil lilo doesn't
work.

So, does anyone have a clue what is causing the unresolved symbols or if I
will be able to boot once I can use a lvm modules?????

I would apreciate all the help you can offer me.

Mark Kikken
 

-- 
Sent through GMX FreeMail - http://www.gmx.net

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list