Problems with chroot

Aaron Isotton aisotton at bigdfoot.com
Sat Oct 27 09:12:38 PDT 2001


Hi,
I am installing LFS and I have come to the point of "Installing Basic 
System Software". Everything worked fine with chroot, I could install glibc 
and some other packages but then I exited and thought I'd continue later.

But now everytime I type

root at linux:/ > chroot /mnt/lfs /usr/bin/env -i HOME=/root TERM=$TERM 
/bin/bash --login

It says

env: loadlocale.c:220: _nl_load_locale: Assertion `idx % __alignof__ 
(u_int32_t) == 0' failed.
Aborted

I thought there was a problem with env, so I tried

root at linux:/ > chroot /mnt/lfs /bin/bash --login

But the same thing happened.

bash: loadlocale.c:220: _nl_load_locale: Assertion `idx % __alignof__ 
(u_int32_t) == 0' failed.
Aborted

I tried reinstalling sh-utils, but nothing changed. I think that there is a 
problem with glibc already being installed and interfering with some 
programs. What can I do?

Regards,
Aaron Isotton
                                                                
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list