Unable to mount rot fs on 16:41

Christian Lang Ziege.Lang at web.de
Mon Oct 22 14:56:32 PDT 2001


Hello all!

I've got a problem in creating a LFS-System.
I'm using SuSE 7.1
I've three harddisks (2 SCSI, 1 EIDE):
 /dev/sda1 (Windows)
 /dev/sda5 (SuSE reiserfs)
 /dev/sda6 (swap)
 
 /dev/sdb1 (Data)

 /dev/hdd1 (LFS)

My Bios Boot Sequence is: SCSI, A, C

My Problem:

All what I've made with LFS was no problem until I
try to start the LFS-System I get the Error:

---------------schnipp--------------
VFS: Cannot open root device "1641" or 16:41
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount rot fs on 16:41
---------------schnapp--------------

When I copy the original SuSE-Kernel into lfs
I can boot, but have no swap with this Error:

---------------schnipp--------------
swapon /dev/sda6: No such device
mount: the kernel does not recognize /dev/sda5 as a block device
                  (maybe 'insmod driver'?)
---------------schnapp--------------

The same when I try to mount any other partition.

In the end of the mail, I give you:
 - my SuSE fstab
 - my LFS fstab
 - my lilo.conf

Can anybody help me?

Thanks

---------------schnipp-(SuSE fstab) ------------
/dev/sda6  swap        swap      defaults            0   0
/dev/sda5  /           reiserfs  defaults            1   1
/dev/sda1  /windows/C  vfat      noauto,user         0   0
/dev/sdb1  /windows/D  vfat      noauto,user         0   0

/dev/hdd1  /lfs        reiserfs  defaults            0   0

/dev/sr0   /cdrecorder auto      ro,noauto,user,exec 0   0
/dev/sr1   /cdrom      auto      ro,noauto,user,exec 0   0

/dev/fd0   /floppy     auto      noauto,user         0   0

proc       /proc       proc      defaults            0   0
---------------schnapp--------------------------
---------------schnipp-(LFS fstab) -------------
# Begin /etc/fstab

/dev/hdd1   /          reiserfs   defaults              1   1
/dev/sda6   swap       swap       defaults              0   0

/dev/sda5   /mnt/lin   reiserfs   defaults              0   0
/dev/sda1   /mnt/win   vfat       noauto,user           0   0
/dev/sdb1   /mnt/dat   vfat       noauto,user           0   0
/dev/sr0    /mnt/rec   auto       ro,noauto,user,exec   0   0
/dev/sr1    /mnt/rom   auto       ro,noauto,user,exec   0   0
/dev/fd0    /mnt/flo   auto       noauto,user           0   0

proc        /proc      proc       defaults              0   0

# End /etc/fstab
---------------schnapp--------------------------
---------------schnipp-(lilo.conf) -------------
boot = /dev/sda
vga = normal
read-only
menu-scheme = Wg:kw:Wg:Wg
lba32
prompt
timeout = 200
message = /boot/message
default = linux

  image  = /boot/vmlinuz
  label  = linux
  root   = /dev/sda5
  initrd = /boot/initrd

  other  = /dev/sda1
  label  = windows

  image  = /boot/vmlinuz_24
  label  = linux_2.4
  root   = /dev/sda5
  initrd = /boot/initrd_24
  optional

  image  = /boot/vmlinuz.suse
  label  = suse
  root   = /dev/sda5
  initrd = /boot/initrd.suse
  optional

  image  = /boot/memtest.bin
  label  = memtest86

  image  = /boot/vmlinuz
  label  = lfs
  root   = /dev/hdd1
  read-only
---------------schnapp--------------------------


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list