Problem compiling fileutils

Erika Pacholleck pchllck at nexgo.de
Sun Oct 21 03:20:04 PDT 2001


[20.10.01 21:02 -0400] David <-- :
> When compiling fileutils-4.1 in chapter 6 I get the following error
> make  all-recursive
> make[1]: Entering directory `/usr/src/fileutils-4.1'
> Making all in lib
> make[2]: Entering directory `/usr/src/fileutils-4.1/lib'
> cd .. && \
>   CONFIG_HEADERS= CONFIG_LINKS= \
>     CONFIG_FILES=lib/Makefile /bin/sh ./config.status
>     config.status: creating lib/Makefile
>     make[2]: Leaving directory `/usr/src/fileutils-4.1/lib'

>     make[2]: Entering directory `/usr/src/fileutils-4.1/lib'
>     Makefile:624: *** missing separator.  Stop.

>     make[2]: Leaving directory `/usr/src/fileutils-4.1/lib'
>     make[1]: *** [all-recursive] Error 1
>     make[1]: Leaving directory `/usr/src/fileutils-4.1'
>     make: *** [all] Error 2
> 
> I got the same error compiling on another computer, but it dissappeared
> after removing the sourcees and unpacking it again. This is on a laptop and
> I have tried several times to get this to work.

Before starting configure make sure you always use a freshly unpacked
source package (this is mentioned in the book).

If you did indead use freshly unpacked sources and you run into this,
a Makefiles missing separator means the line is not beginning with a TAB. 
make[x]: Entering ... tells you the directory
Makefile:xxx ... tells you which file and which line
Just go there and make sure the line begins with a TAB.

-- 
Erika Pacholleck <pchllck at nexgo.de> @@ -18,9 +18,12 @@ -p+pa -h+ho -c+ec
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list