Receiving fatal error when trying to compile gcc-2.95-3

Randy Chambers ld at tampabay.rr.com
Thu Oct 18 10:16:30 PDT 2001


Using LFS v3.0
RedHat Linux 7.1 kernel 2.4.12

I'm trying to compile package gcc-2.95.3 however after unzipping the
patch, changing dir to gcc-2.95.3 and running the following commands:

patch -Np1 -i ../gcc-2.95.3-2.patch &&
mkdir ../gcc-build &&
cd ../gcc-build &&
../gcc-2.95.3/configure --prefix=/usr --enable-languages=c,c++ \
   --disable-nls --disable-shared --enable-threads=posix &&
make BOOT_LDFLAGS=-static bootstrap &&
make prefix=$LFS/usr install &&
cd $LFS/lib &&
ln -sf ../usr/bin/cpp &&
cd $LFS/usr/lib &&
ln -sf ../bin/cpp &&
cd $LFS/usr/bin &&
ln -sf gcc cc

I receive the following error message:


**Begin error message**

expr.o: No space left on device
/tmp/ccUoLZMj.s: Assembler messages:
/tmp/ccUoLZMj.s:43506: FATAL: Can't write expr.o: No space left on
device
make[2]: *** [expr.o] Error 1
make[2]: Leaving directory `/mnt/lfs/usr/src/3.0/gcc-build/gcc'
make[1]: *** [bootstrap] Error 2
make[1]: Leaving directory `/mnt/lfs/usr/src/3.0/gcc-build/gcc'
make: *** [bootstrap] Error 2

**End error message**

I followed the exact steps from
http://hints.linuxfromscratch.org/hints/one-partition-hint.txt made the
lfs.disk file the size of 750MB.

I tried to compile this package twice and received the exact same error
message.


The only deviation that I made from the book, was downloading kernel
version 2.4.12

Thanks,
Randy Chambers

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list