bash 2.04 compiling error

luca de filippis merloplano at tiscalinet.it
Sat Oct 13 10:20:28 PDT 2001


hi, my name is luca.
i like the idea behind lfs, so i decided to try with lfs 2.4.4.
i immediatly face a problem with bash 2.04, copying what written in chap 
5. this is the error:

/lib/libcurses.a(lib_trace.o): In function `trace':
lib_trace.o(.text+0x0): multiple definition of `trace'
error.o:/lfs/usr/src/bash-2.04/error.c:478: first defined here
/usr/bin/ld: Warning: size of symbol `trace' changed from 177 to 7 in 
lib_trace.o collect2: ld returned 1 exit status
make: *** [bash] Error 1

i even tried to compile without --with-curses, no way.

i do ldconfig after each package. later on, i've succed compiling all the 
other package in chap 5 but shellutil. 
daddy-linux was easy-linux, kernel 2.2.16 and gcc 2.95.1. 
(btw, my patch command does not recognize -i option, so i force 
with <../filename). 

i've tried to find a solution in a local mailing list, but i've collected 
another guy with the same trouble. 

i've already checked the libcurses.a links.
can you give me some help?

thanx, luca

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list