can´t mount filesystems :(

Frank Mikkelsen frank.mikkelsen at telia.com
Sat Oct 6 05:06:03 PDT 2001


Gerard Beekmans wrote:

> On Wed, Oct 03, 2001 at 12:50:14AM +0200, Enrico wrote:
> 
>> Hi,
>> 
>> sorry for my bad english, hope, everybody will understand, what I wanna to
>> say!
>> I have installed my lfs system and after a reboot, there are no mounted
>> filesystems. he can´t mount swap, but the root part, but here i get an error
>> with a bad superblock. so, I can choice: reboot or shell: if i take a shell
>> and look into /dev, there is nothing inside :(
>> /proc/devices is missing, too
>> 
>> If I boot into my mandrake box, there are no errors on the lfs root
>> partition and the devices in /lfs/dev are correct.
>> 
>> has anybody a tip or a hint?
> 
> 
> Are you sure /etc/lilo.conf has the right partition listed for LFS? If the
> wrong partition is listed in the lfs section, the kernel will mount the
> wrong system as / and things won't work properly.

Hi, I have the same problem as Enrico has. When booting my LFS (based on 
LFS 3.0) I get the following errors:

Activating swap...swapon: cannot stat /dev/hda1 No such file or directory
Checking file systems...
ext2fs_check_if_mount: No such file or directory while determining 
whether /dev/hda2 is mounted
fsck.ext2: No such file or directory while trying to open /dev/hda2 (null):
After that I get a maintenance shell login....

Here's my /etc/lilo.conf:
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
vga=normal
default=linux
lba32
prompt
timeout=50
image=/boot/vmlinuz
	label=linux
	root=/dev/hda3
	append=" quiet"
	vga=788
	read-only
image=/boot/vmlinuz
	label=linux-nonfb
	root=/dev/hda3
	read-only
image=/boot/vmlinuz
	label=failsafe
	root=/dev/hda3
	append=" failsafe"
	read-only
other=/dev/fd0
	label=floppy
	unsafe
image=/boot/lfskernel
         label=lfs
         root=/dev/hda2
	read-only

This is what is in $LFS/boot:
drwxr-xr-x    2 root     root         4096 Oct  6 13:23 ./
drwxr-xr-x   17 root     root         4096 Oct  5 00:59 ../
-rw-r--r--    1 root     root       488539 Oct  6 08:46 System.map
-rw-r--r--    1 root     root         7116 Oct  5 19:09 boot-bmp.b
-rw-r--r--    1 root     root         5868 Oct  6 09:23 boot-graphic.b
-rw-r--r--    1 root     root         7092 Oct  5 19:09 boot-menu.b
-rw-r--r--    1 root     root         5332 Oct  5 19:09 boot-text.b
lrwxrwxrwx    1 root     root           11 Oct  6 13:23 boot.b -> 
boot-menu.b
-rw-r--r--    1 root     root          728 Oct  5 19:09 chain.b
-rw-r--r--    1 root     root       940361 Oct  6 08:46 lfskernel
-rw-r--r--    1 root     root          512 Oct  5 19:09 mbr.b
-rw-r--r--    1 root     root        35130 Oct  6 09:24 message-graphic
-rw-r--r--    1 root     root          656 Oct  5 19:09 os2_d.b
-rw-r--r--    1 root     root       833285 Oct  6 08:52 vmlinuz

This is the list over mounted file systems while booted into Mandrake 8.0:
/dev/hda3 on / type ext2 (rw,noatime)
none on /proc type proc (rw)
none on /dev/pts type devpts (rw,mode=0620)
/mnt/cdrom on /mnt/cdrom type supermount (rw,fs=iso9660,dev=/dev/cdrom)
/mnt/floppy on /mnt/floppy type supermount (rw,fs=vfat,dev=/dev/fd0)
/dev/hda2 on /mnt/lfs type ext2 (rw,noatime)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0664,devgid=43)

Anyone who can help me with this problem?

Thank you

Frank Mikkelsen

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list