Building on LFS

Jeroen Coumans jeroencoumans at hotmail.com
Thu Oct 4 02:08:23 PDT 2001


----- Original Message -----
From: "Frank Schafer" <frank.schafer at setuza.cz>
To: <lfs-support at linuxfromscratch.org>
Sent: Thursday, October 04, 2001 8:24 AM
Subject: Building on LFS


> Hi all,
>
> I've tried to use LFS as I know it on "normal" GNU-Linux systems
> (building - configuring - using) but howdy ...
>
> Something seems to be VERY wrong with the glibc / gcc / kernel
> combination (???).
>
> How I built:
> I used a Slackware-7.1 installation as the mother-system (one PC). I
> took a naked host which I started using
> floppy disks with a NFS enabled kernel and some nesessary tools for
> login, NFS-connect, FS layout and so on.
> I started the child-PC, set up the FS, exported / to the mother, built
> all static linked tools on the mother system,
> installed the results via NFS to the child.
> Instead of the ``chroot'' I restarted the child having now all static
> linked tools available.
> The rest of all went due to the LFS-BOOK-3.0-pre3.
> Compiling XFree4.0.1 made some problems, but went well at last.
>
> How problems showed up:
> I wasn't very glad to stick with twm, so I choosed to use AfterStep
with
> GNOME enabled. Compiling GNOME I
> ran into trouble: During the build of libgtop I got an unresolved
> external  error in libz
>
> libz.so.1: atexit - unresolved external
>
> Libz itself doesn't use atexit, and ``readelf -s libc.so.6'' showed
> atexit global there.
>
> What I've tried:
> I think something went wrong with the glibc / gcc build (dynamic
> version).
> The docs of glibc-2.2.3 say, that GNU uses gcc-2.95.3 to compile it.
> That are the packages I used. The docs of
> glibc-2.2.3 say further, that the include files of a 2.2.x kernel have
> to be available. I built the LFS system from all
> the beginning with kernel 2.4.6 ( the mother ran 2.2.16 ). So on the
> child system had only the include files for a
> 2.4.x kernel available.
> So I've extracted the 2.2.16 kernel and began ( on the LFS system ) to
> compile the static linked tools onesmore.
> How, ... nearly everything fails due to unresolved externals in
libc.a.
>
> Has anybody an idea, how to solve this?
> Frank
>
Did you use strip? The pre-3 version contained a very dangerous strip
command that hoses your libc. Look at www.hints.linuxfromscratch.org
there's a hint which guides you through the process of fixing it. And
then perhaps upgrade to 3.0 for various other bugfixes.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list