Trouble compiling GCC-2.95.3

Giles Bathgate dt98gmb at brunel.ac.uk
Wed Oct 3 17:01:49 PDT 2001


On Wednesday 03 October 2001 11:04 pm, you wrote:
> On Wed, Oct 03, 2001 at 09:13:38PM +0100, Giles Bathgate wrote:
> > when i used:   <input>   patch -Np1 -i ../gcc-2.95.3-2.patch     
> > </input>
>
> Did you run this inside the gcc-2.95.3 directory, or did you run it from
> inside another directory, like $LFS/usr/src or something like that?
>
> > I didn't think this should matter if I ommitted the patch.
>
> It shouldn't, but you do want the patch, else you will get problems later
> on when compiling certain libraries.

of course, I ran the command in the $LFS/usr/src/gcc-2.95.3/     directory
if i were to run the command in the $LFS/usr/src/ directory it would give the 
error

patch: **** Can't open patch file ../gcc-2.95.3-2.patch : No such file or 
directory

I ran the command in the $LFS/usr/src/gcc-2.95.3/     directory and i got:

can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -uNr gcc-2.95.3.orig/gcc/c-common.c gcc-2.95.3/gcc/c-common.c
|--- gcc-2.95.3.orig/gcc/c-common.c     Tue Sep  7 18:11:16 1999
|+++ gcc-2.95.3/gcc/c-common.c  Sat Aug 18 07:18:42 2001
--------------------------
File to patch:

anyway even if i solve this, I still have the outstanding problem with the 
configure not running properly and giving me the No rule to make target 
`bootstrap'. problem

I will try hard to see if I can solve this myself.......but I have had no 
luck so far

Thanks 

Giles.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list