Trouble compiling GCC-2.95.3

Giles Bathgate dt98gmb at brunel.ac.uk
Wed Oct 3 13:13:38 PDT 2001


On Wednesday 03 October 2001 8:41 pm, you wrote:
> On Wed, Oct 03, 2001 at 06:37:25PM +0100, Giles Bathgate wrote:
> <cut>
>
> > No configuration information in texinfo
> > Configuring gcc...
> > No configuration information in gcc
> > Configuring etc...
>
> <cut>
>
> Everything looks good, except for those two lines above "No configuration
> information in xyz"
>
> It seems something is wrong with your gcc-2.95.3 directory. Have you tried
> removing the gcc-2.95.3 directory and unpack it again from the
> gcc-2.95.3.tar.bz2 file?

yes I did, try to remove the directory and re-unpack the package.

Ah I did forget to mention however that I have not managed to apply the patch 
for GCC-2.95.3

when i used:   <input>   patch -Np1 -i ../gcc-2.95.3-2.patch      </input>

i get:

<output>

can't find file to patch at input line 4 Perhaps you used the wrong -p or 
--strip option? 
The text leading up to this was: 
-------------------------- 
|diff -uNr gcc-2.95.3.orig/gcc/c-common.c gcc-2.95.3/gcc/c-common.c 
|--- gcc-2.95.3.orig/gcc/c-common.c     Tue Sep  7 18:11:16 1999 
|+++ gcc-2.95.3/gcc/c-common.c  Sat Aug 18 07:18:42 2001 
-------------------------- 
File to patch:

</output>

(MARKUP IS FOR CLARITY)

I didn't think this should matter if I ommitted the patch.

should i try to update the textinfo package on my base system?

EXTRA BACKGROUND INFO:
when compiling fileutils I found that I had to update 

Bison
M4
autoconf
automake
perl

Packages in my current system (SuSE 7.1). before it would compile properly.
I tried to update patch but that wouldnt compile either.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list