Unable to build glibc2.2.4 wit Mandrake8.0

Romeo Kienzler ormium at web.de
Mon Oct 1 01:02:52 PDT 2001


Hi Gerard,

I tried, what you told me.

>
> did you copy the linuxthreads_db directory too? You shouldn't just copy
> directories, but actually unpack the tarball inside the glibc-2.2.4
> directory like the instructions tell.

I copied the tarball first to /usr/src/glibc-2-2-4 and unpacked it.
Same problem.
Then i did the same in the /usr/src/glibc-build but the eror is still:

On GNU/Linux systems it is normal to compile GNU libc with the
?linuxthreads! addon. Without that, the library will be incompatibel with
normal GNU/Linux systems.

>
> Enter chroot like you did in the beginning of chapter 6. Then run:
> cat /usr/include/linux/version.h
>
> if the file doens't exist, or doens't contain something like this:
> #define UTS_RELEASE "2.4.10"
> #define LINUX_VERSION_CODE 132103
> #define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))

It looks all like this.

Thank you for your help, greetings romeo


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list