Stripping Debug Errors

Paul Abraham Paul.Abraham at consultjoa.com
Fri Nov 30 02:50:13 PST 2001


jpb [mailto:jamieburt at myhomenetwork.fsnet.co.uk] wrote:
> However, small problem in running the strip --debug
> command, as in the book
> 
> results in "unrecognized file format error" scrolling
> forever as it checks the files.
> 
> I also tried a script which somebody had posted in the
> support group which also gave me errors
> 
> but this time proc - permission denied ...ad infinitum....]
> 
> Can anybody suggest anything please?

I'm not sure which strip command you used, but here's one
that doesn't attempt to strip the /proc directory (found by
doing a Google search on "linuxfromscratch strip proc":

find / -path /proc -prune -o -type f -exec strip --strip-debug '{}' ';'

[It should all be on one line, but I can't tell if
Outlook has wrapped it for your convenience!  Grrrr.]

You will still get invalid file format errors, but won't
get stuck in /proc

There's also another one-liner when you do the Google search
which also strips the /dev and /dev/pts directories.

DISCLAIMER: I haven't yet got round to stripping symbols
from my LFS system!

Paul.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list